summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/guix.texi2
-rw-r--r--gnu/packages/xorg.scm4
-rw-r--r--gnu/services/xorg.scm2
3 files changed, 3 insertions, 5 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index b1b6d98e74..bb5f29277f 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -24104,7 +24104,7 @@ SLiM@. Thus, the configuration of these display managers aggregates an
@table @asis
@item @code{modules} (default: @code{%default-xorg-modules})
This is a list of @dfn{module packages} loaded by the Xorg
-server---e.g., @code{xf86-video-vesa}, @code{xf86-input-keyboard}, and so on.
+server---e.g., @code{xf86-video-vesa}, @code{xf86-input-libinput}, and so on.
@item @code{fonts} (default: @code{%default-xorg-fonts})
This is a list of font directories to add to the server's @dfn{font path}.
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 3944aec0d4..1dc97334fd 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2620,6 +2620,8 @@ It is used to control the pointer with a joystick device.")
(base32
"0mvwxrnkq0lzhjr894p420zxffdn34nc2scinmp7qd1hikr51kkp"))))
(build-system gnu-build-system)
+ ;; Linux is no longer supported since 2.0.0, use libinput or evdev instead.
+ (supported-systems '("i586-gnu" "x86_64-gnu"))
(inputs (list xorg-server))
(native-inputs (list pkg-config))
(home-page "https://www.x.org/wiki/")
@@ -6222,7 +6224,6 @@ basic eye-candy effects.")
xorg-server
xf86-video-dummy
xf86-input-mouse
- xf86-input-keyboard
xxhash
python-pillow
;; Optional dependencies.
@@ -6288,7 +6289,6 @@ basic eye-candy effects.")
"\nSection \"Files\"\nModulePath \""
#$(this-package-input "xf86-video-dummy") "/lib/xorg/modules,"
#$(this-package-input "xf86-input-mouse") "/lib/xorg/modules,"
- #$(this-package-input "xf86-input-keyboard") "/lib/xorg/modules,"
#$(this-package-input "xorg-server") "/lib/xorg/modules\"\n"
"EndSection\n\n"))
(substitute* '("xpra/scripts/config.py"
diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index d3912a7de6..1d7e3ae973 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -165,9 +165,7 @@
;; Libinput is the new thing and is recommended over evdev/synaptics:
;; <http://who-t.blogspot.fr/2015/01/xf86-input-libinput-compatibility-with.html>.
xf86-input-libinput
-
xf86-input-evdev
- xf86-input-keyboard
xf86-input-mouse))
(define %default-xorg-fonts