summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tbb.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index f22282264c..b2d276ac8b 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016 Nikita <[email protected]>
;;; Copyright © 2019 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2021 Guillaume Le Vaillant <[email protected]>
-;;; Copyright © 2022 Efraim Flashner <[email protected]>
+;;; Copyright © 2022, 2023 Efraim Flashner <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,7 +48,11 @@
(patches (search-patches "tbb-other-arches.patch"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DTBB_STRICT=OFF"))) ;; Don't fail on warnings
+ `(#:configure-flags
+ '(,@(if (target-riscv64?)
+ '("-DTBB_TEST_LINK_FLAGS=-latomic")
+ `())
+ "-DTBB_STRICT=OFF"))) ;; Don't fail on warnings
(home-page "https://www.threadingbuildingblocks.org")
(synopsis "C++ library for parallel programming")
(description