summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/compression.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 2b5cbf8850..4e0d4e9196 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021, 2022 Ricardo Wurmus <[email protected]>
;;; Copyright © 2015, 2017, 2018 Leo Famulari <[email protected]>
;;; Copyright © 2015 Jeff Mickey <[email protected]>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <[email protected]>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Ben Woodcroft <[email protected]>
;;; Copyright © 2016 Danny Milosavljevic <[email protected]>
;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <[email protected]>
@@ -813,8 +813,11 @@ decompression of some loosely related file formats used by Microsoft.")
(build-system gnu-build-system)
(outputs (list "out" "static"))
(native-inputs
- (list ;; For tests.
- python valgrind))
+ (append
+ (list python) ;; For tests.
+ (if (member (%current-system) (package-supported-systems valgrind))
+ (list valgrind)
+ '())))
(arguments
`(;; Not designed for parallel testing.
;; See https://github.com/lz4/lz4/issues/957#issuecomment-737419821