summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/xf86-video-nouveau-fixup-ABI.patch64
-rw-r--r--gnu/packages/xorg.scm7
3 files changed, 3 insertions, 69 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a62d681c58..aa91977391 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2399,7 +2399,6 @@ dist_patch_DATA = \
%D%/packages/patches/x265-arm-flags.patch \
%D%/packages/patches/xdg-desktop-portal-disable-portal-tests.patch\
%D%/packages/patches/xdg-desktop-portal-wlr-harcoded-length.patch\
- %D%/packages/patches/xf86-video-nouveau-fixup-ABI.patch \
%D%/packages/patches/xf86-video-siliconmotion-fix-ftbfs.patch \
%D%/packages/patches/xfig-Enable-error-message-for-missing-libraries.patch \
%D%/packages/patches/xfig-Fix-double-free-when-requesting-MediaBox.patch \
diff --git a/gnu/packages/patches/xf86-video-nouveau-fixup-ABI.patch b/gnu/packages/patches/xf86-video-nouveau-fixup-ABI.patch
deleted file mode 100644
index a18e3f8ab9..0000000000
--- a/gnu/packages/patches/xf86-video-nouveau-fixup-ABI.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From e80e73ced69b15662103d0fd6837db4ce6c6eb5b Mon Sep 17 00:00:00 2001
-From: Dave Airlie <[email protected]>
-Date: Mon, 13 Jul 2020 09:20:15 +1000
-Subject: [PATCH] nouveau: fixup driver for new X server ABI
-
----
- src/compat-api.h | 4 ++++
- src/nouveau_exa.c | 2 +-
- src/nv_driver.c | 6 +++---
- 3 files changed, 8 insertions(+), 4 deletions(-)
-
-diff --git a/src/compat-api.h b/src/compat-api.h
-index fde2f4b..8a1fcf9 100644
---- a/src/compat-api.h
-+++ b/src/compat-api.h
-@@ -102,4 +102,8 @@
-
- #endif
-
-+#if ABI_VIDEODRV_VERSION < SET_ABI_VERSION(25, 2)
-+#define secondary_dst slave_dst
-+#endif
-+
- #endif
-diff --git a/src/nouveau_exa.c b/src/nouveau_exa.c
-index 55df6f8..db3b112 100644
---- a/src/nouveau_exa.c
-+++ b/src/nouveau_exa.c
-@@ -157,7 +157,7 @@ nouveau_exa_destroy_pixmap(ScreenPtr pScreen, void *priv)
-
- #ifdef NOUVEAU_PIXMAP_SHARING
- static Bool
--nouveau_exa_share_pixmap_backing(PixmapPtr ppix, ScreenPtr slave, void **handle_p)
-+nouveau_exa_share_pixmap_backing(PixmapPtr ppix, ScreenPtr secondary, void **handle_p)
- {
- struct nouveau_bo *bo = nouveau_pixmap_bo(ppix);
- struct nouveau_pixmap *nvpix = nouveau_pixmap(ppix);
-diff --git a/src/nv_driver.c b/src/nv_driver.c
-index e72a6b6..f9ab4af 100644
---- a/src/nv_driver.c
-+++ b/src/nv_driver.c
-@@ -559,16 +559,16 @@ redisplay_dirty(ScreenPtr screen, PixmapDirtyUpdatePtr dirty)
- {
- RegionRec pixregion;
-
-- PixmapRegionInit(&pixregion, dirty->slave_dst);
-+ PixmapRegionInit(&pixregion, dirty->secondary_dst);
-
-- DamageRegionAppend(&dirty->slave_dst->drawable, &pixregion);
-+ DamageRegionAppend(&dirty->secondary_dst->drawable, &pixregion);
- #ifdef HAS_DIRTYTRACKING_ROTATION
- PixmapSyncDirtyHelper(dirty);
- #else
- PixmapSyncDirtyHelper(dirty, &pixregion);
- #endif
-
-- DamageRegionProcessPending(&dirty->slave_dst->drawable);
-+ DamageRegionProcessPending(&dirty->secondary_dst->drawable);
- RegionUninit(&pixregion);
- }
-
---
-2.33.1
-
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index ce2e5024ad..1cbdcf33b0 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3167,15 +3167,14 @@ supported, and the RENDER extension is not accelerated by this driver.")
(define-public xf86-video-nouveau
(package
(name "xf86-video-nouveau")
- (version "1.0.17")
+ (version "1.0.18")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/driver/xf86-video-nouveau-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
- (base32 "0sqm1jwjg15sp8v7039y2hsbhph8gpjd2bdzcqqiij2mgbi254s9"))
- (patches (search-patches "xf86-video-nouveau-fixup-ABI.patch"))))
+ (base32 "1z9bqfr81w2ahq2vyphgjbl0ffxndrpxb4mqqly76srjcj7d6ap8"))))
(build-system gnu-build-system)
(inputs (list xorg-server))
(native-inputs (list pkg-config))