summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm25
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d7fd1f4a3e..54885d2b90 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8244,6 +8244,31 @@ them.")
"Go long flag: a light-weight long and short command line option parser.")
(license license:bsd-3)))
+(define-public go-github-com-kataras-pio
+ (package
+ (name "go-github-com-kataras-pio")
+ (version "0.0.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kataras/pio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z0fkhs6amnkvb02519pfxy2x2r5sfmvdzxfi31ipa17m98pk3bq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kataras/pio"))
+ (home-page "https://github.com/kataras/pio")
+ (synopsis "Pill for Input/Output")
+ (description
+ "PIO is a low-level package that provides a way to centralize different
+output targets. Supports colors and text decoration to all popular
+terminals.")
+ (license license:bsd-3)))
+
(define-public go-github-com-kballard-go-shellquote
;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
(let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cccd58e043..69b0fb1535 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1242,30 +1242,6 @@ networks where it would otherwise be blocked or heavily throttled.")
(description "GoLog is a level-based logger written in Go.")
(license license:bsd-3)))
-(define-public go-github-com-kataras-pio
- (package
- (name "go-github-com-kataras-pio")
- (version "0.0.13")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/kataras/pio")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1z0fkhs6amnkvb02519pfxy2x2r5sfmvdzxfi31ipa17m98pk3bq"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/kataras/pio"))
- (home-page "https://github.com/kataras/pio")
- (synopsis "Pill for Input/Output")
- (description "PIO is a low-level package that provides a way to centralize
-different output targets. Supports colors and text decoration to all popular
-terminals.")
- (license license:bsd-3)))
-
(define-public go-github-com-kortschak-utter
(package
(name "go-github-com-kortschak-utter")