summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTomas Volf <[email protected]>2025-01-29 00:00:15 +0100
committerHilton Chain <[email protected]>2025-01-30 20:18:04 +0800
commitf7fc4caf7da8f1d7cc76b3bc6ac0c4e643507454 (patch)
tree281d9c2ef669e61c9f4c736c5fc1606464646ccf /gnu
parent41ab2ddd9bb5d19ece219d9f175f5215f09a7fb1 (diff)
gnu: smartmontools: Fix PATH in smartd_warning.sh.
The script started with reset of the $PATH to a value not suitable to Guix. In addition, the script requires coreutils and sed, so add those into the $PATH. * gnu/packages/admin.scm (smartmontools)[inputs]: Add sed, coreutils-minimal. [arguments]<#:configure-flags>: Pass --with-scriptpath=. Change-Id: Ide97f572e6f369fe24337f945474dc7a65584eda Signed-off-by: Hilton Chain <[email protected]> Modified-by: Hilton Chain <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 18f4d55c70..8e9dea4e2d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3051,9 +3051,18 @@ various ways that may be running with too much privilege.")
"0gcrzcb4g7f994n6nws26g6x15yjija1gyzd359sjv7r3xj1z9p9"))))
(build-system gnu-build-system)
(arguments
- (list #:make-flags
- #~(list "BUILD_INFO=\"(Guix)\"")))
- (inputs (list libcap-ng))
+ (list
+ #:make-flags
+ #~(list "BUILD_INFO=\"(Guix)\"")
+ #:configure-flags
+ #~(list (format #f "--with-scriptpath=~{~a:~}$PATH"
+ (map (lambda (pkg)
+ (in-vicinity pkg "bin"))
+ '#$(list (this-package-input "coreutils-minimal")
+ (this-package-input "sed")))))))
+ (inputs (list coreutils-minimal
+ libcap-ng
+ sed))
(home-page "https://www.smartmontools.org/")
(synopsis "S.M.A.R.T. harddisk control and monitoring tools")
(description