summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves via Guix-patches via <[email protected]>2025-01-30 10:04:23 +0100
committerHilton Chain <[email protected]>2025-01-30 20:18:05 +0800
commitc5a4937f0e19f0aca0d01b10110c9728ecb4b22e (patch)
tree83c681cf381d7b2241e8470fc70bc34ed7b8d4fb /gnu
parentf7fc4caf7da8f1d7cc76b3bc6ac0c4e643507454 (diff)
gnu: git-filter-repo: Fix build.
* gnu/packages/version-control.scm (git-filter-repo)[arguments]<#:phases>: Adapt phase 'unpack-git-source to handle the asciidoc.conf renamed to asciidoc.conf.in in upstream git. * gnu/packages/patches/git-filter-repo-generate-doc.patch: Refresh patch. Signed-off-by: Hilton Chain <[email protected]> Change-Id: Icbe5729c17c1d865200612d4a571fe42a1c5741b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/git-filter-repo-generate-doc.patch20
-rw-r--r--gnu/packages/version-control.scm7
2 files changed, 15 insertions, 12 deletions
diff --git a/gnu/packages/patches/git-filter-repo-generate-doc.patch b/gnu/packages/patches/git-filter-repo-generate-doc.patch
index 4535ae5bc4..baf6fd4f8f 100644
--- a/gnu/packages/patches/git-filter-repo-generate-doc.patch
+++ b/gnu/packages/patches/git-filter-repo-generate-doc.patch
@@ -1,4 +1,4 @@
-From 56e6857e71d2b2a2236625f3c8b112bd40a8b164 Mon Sep 17 00:00:00 2001
+From d44e90189f3dfc47b86a457cb3493478207fa14d Mon Sep 17 00:00:00 2001
From: Josselin Poiret <[email protected]>
Date: Fri, 16 Feb 2024 00:21:06 +0800
Subject: [PATCH] Add documentation generation.
@@ -53,13 +53,13 @@ index 0000000..d81ffbe
+man: man1/git-filter-repo.1
+html: html/git-filter-repo.html
diff --git a/Makefile b/Makefile
-index a443450..d965ae5 100644
+index 3330a1d..801da8f 100644
--- a/Makefile
+++ b/Makefile
-@@ -20,21 +20,10 @@ test:
+@@ -21,21 +21,10 @@ test:
fixup_locale:
sed -ie s%@@LOCALEDIR@@%$(localedir)% git-filter-repo
-
+
-# People installing from tarball will already have man1/git-filter-repo.1 and
-# html/git-filter-repo.html. But let's support people installing from a git
-# clone too; for them, just cheat and snag a copy of the built docs that I
@@ -67,7 +67,7 @@ index a443450..d965ae5 100644
-snag_docs: Documentation/man1/git-filter-repo.1 Documentation/html/git-filter-repo.html
+doc:
+ $(MAKE) -C Documentation man html
-
+
-Documentation/man1/git-filter-repo.1:
- mkdir -p Documentation/man1
- git show origin/docs:man1/git-filter-repo.1 >Documentation/man1/git-filter-repo.1
@@ -78,11 +78,9 @@ index a443450..d965ae5 100644
-
-install: snag_docs #fixup_locale
+install: doc #fixup_locale
- install -Dm0755 git-filter-repo "$(DESTDIR)/$(bindir)/git-filter-repo"
- install -dm0755 "$(DESTDIR)/$(pythondir)"
+ $(INSTALL) -Dm0755 git-filter-repo "$(DESTDIR)/$(bindir)/git-filter-repo"
+ $(INSTALL) -dm0755 "$(DESTDIR)/$(pythondir)"
ln -sf "$(bindir)/git-filter-repo" "$(DESTDIR)/$(pythondir)/git_filter_repo.py"
-
-base-commit: cbc6535694380d3a3bf3e5c96410d4ce7e8de94f
---
-2.41.0
+--
+2.47.1
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 636509d6c5..09973c1f9c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -4434,7 +4434,12 @@ TkDiff is included for browsing and merging your changes.")
#:source #+(package-source git))
(for-each
(cut install-file <> doc-source)
- (find-files "." "asciidoc\\.conf$|manpage.*\\.xsl$"))
+ (find-files "." "asciidoc\\.conf\\.in$|manpage.*\\.xsl$"))
+ ;; These attributes are probably not needed.
+ (with-directory-excursion doc-source
+ (substitute* "asciidoc.conf.in"
+ (("@GIT_(VERSION|DATE)@") ""))
+ (rename-file "asciidoc.conf.in" "asciidoc.conf"))
(chdir old-path)
(delete-file-recursively "git-source"))))
(add-before 'build 'set-pythondir