summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-20 19:44:05 +0000
committerSharlatan Hellseher <[email protected]>2025-01-29 23:04:31 +0000
commit9d99efa22566536b5586bb403f5914686caa7aa0 (patch)
treeb270983a405a78ae3bf8bba6e4f2b3617b0ea3a0 /gnu
parent82ea580d8310f2fce58329abcfd8e9a1134a12eb (diff)
gnu: Add python-mapsims.
* gnu/packages/astronomy.scm (python-mapsims): New variable. Change-Id: I2bc0941d80d2e0be81ec6a05636c59fc2edc0479
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2c549c43bb..5eb9883464 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2935,6 +2935,71 @@ semi-analytic models, to cosmological hydrodynamic simulations, and even
observationally-derived galaxy merger catalogs.")
(license license:expat)))
+(define-public python-mapsims
+ (package
+ (name "python-mapsims")
+ (version "2.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mapsims" version))
+ (sha256
+ (base32 "15mkdbmcys42vh46wzvaw8avx54dicav3dazflpfr634jw9bd8hs"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; Tests requiring additinal FITS files.
+ ;; <https://portal.nersc.gov/project/cmb>
+ ;; <https://portal.nersc.gov/project/sobs>
+ #~(list "-k" (string-join
+ (list "not test_noise_simulator[ST0]"
+ "test_noise_simulator[ST3]"
+ "test_homogeneous_noise"
+ "test_from_classes_car_healpix"
+ "test_from_config_v02"
+ "test_from_classes"
+ "test_s4sim_202222_ame_high")
+ " and not "))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; pixell==0.17.3
+ (("==0.17.3") ">=0.17.3")))))))
+ (native-inputs
+ (list nss-certs-for-test
+ python-flit-core
+ python-nbformat
+ python-nbval
+ python-pytest
+ python-pytest-astropy))
+ (propagated-inputs
+ (list python-astropy
+ python-healpy
+ python-numpy
+ python-pixell
+ python-pysm3
+ python-pyyaml
+ python-so-noise-models
+ python-toml))
+ (home-page "https://github.com/galsci/mapsims")
+ (synopsis "Map based simulations software for CMB Experiments")
+ (description
+ "This package implements a functionality to produce map based simulations
+for the @url{https://simonsobservatory.org/, Simons Observatory} or other CMB
+experiments. It creates simulated maps in HEALPix and CAR pixelization based
+on:
+@itemize
+@item foreground models included in PySM
+@item custom foregrounds models from the so_pysm_models package
+@item precomputed Cosmic Microwave Background simulations
+@item noise simulations based on expected performance and simulated hitmaps
+@item effect of gaussian beam convolution
+@end itemize")
+ (license license:bsd-2)))
+
(define-public python-pixell
(package
(name "python-pixell")