summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-18 01:44:57 +0000
committerSharlatan Hellseher <[email protected]>2024-12-18 01:45:41 +0000
commit97cb3321c7203cb24aaa2dba2cbe4b5ca90ebcf5 (patch)
treeea855d96b930e85f31a63dd7b76f685ff76d9d44 /gnu
parente8a8c5a13e475f628f90d2d358b6cc13e2faee4b (diff)
gnu: python-textdistance: Update to 4.6.3.
* gnu/packages/python-xyz.scm (python-textdistance): Update to 4.6.3. Fix build. [build-system]: Swap to pyproejct-build-system. [arguments]<phases>: Remove 'delete-external-test. [propagated-inputs]: Add python-jellyfish, python-distance, python-levenshtein, python-pylev, python-pyxdameraulevenshtein, and python-rapidfuzz. [native-inputs]: Remove python-hypothesis, python-isort, python-pytest-runner, and python-tabulate; add python-pytest-xdist, python-setuptools, and python-wheel. Change-Id: I4dae8d535897a1444123ea22603079184435bb5f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 614416e54a..3a7acae776 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13674,34 +13674,35 @@ supports @code{readline} shortcuts.")
(define-public python-textdistance
(package
(name "python-textdistance")
- (version "4.2.1")
+ (version "4.6.3")
(source
(origin
;; There are no tests in the PyPI tarball.
(method git-fetch)
(uri (git-reference
(url "https://github.com/life4/textdistance")
- (commit (string-append "v." version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1g17i356fnny4k6hjr2ayy9k77jbvd6zzmngws2kbrnvhss1wgwf"))))
- (build-system python-build-system)
+ (base32 "1qaplikab46p38jqr93bxd26vvxcnvib15fjxmmp4cbsiy5196sg"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:test-target "pytest"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'delete-external-test
- (lambda _
- ;; All tests in this file require external libraries.
- (delete-file "tests/test_external.py")
- #t)))))
+ (list
+ #:test-flags
+ #~(list "--numprocesses" (number->string (parallel-job-count)))))
(native-inputs
- (list python-hypothesis
- python-isort
- python-numpy
+ (list python-numpy
python-pytest
- python-pytest-runner
- python-tabulate))
+ python-pytest-xdist
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-jellyfish
+ python-distance
+ python-levenshtein
+ python-pylev
+ python-pyxdameraulevenshtein
+ python-rapidfuzz))
(home-page "https://github.com/life4/textdistance")
(synopsis "Compute distance between the two texts")
(description "@code{textdistance} is a pure Python library for comparing