summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-20 19:44:04 +0000
committerSharlatan Hellseher <[email protected]>2025-01-29 23:04:31 +0000
commit82ea580d8310f2fce58329abcfd8e9a1134a12eb (patch)
tree799272fa8ad8f9c3ebe5d8eb26e21581497d10b4 /gnu
parent041994a06544f13a4b1c912f15713a78827cd9b8 (diff)
gnu: Add python-so-noise-models.
* gnu/packages/astronomy.scm (python-so-noise-models): New variable. Change-Id: Ic07bdd4cd0f115ec80594a24b58cb1b0629b7f0f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0797c76a02..2c549c43bb 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3323,6 +3323,39 @@ and the options
to make such analysis both as flexible and clear as possible.")
(license license:bsd-3)))
+(define-public python-so-noise-models
+ (let ((commit "fac881eb5ee012673d8994443caa3c6ad7fac2b6")
+ (revision "0"))
+ (package
+ (name "python-so-noise-models")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch) ; no release on PyPI
+ (uri (git-reference
+ (url "https://github.com/simonsobs/so_noise_models")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02ridxr3a8dx2nwsv386fxin4qs5f7h6q5sk28n9jprgnmgzzsfa"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ; no tests
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-matplotlib
+ python-numpy))
+ (home-page "https://github.com/simonsobs/so_noise_models")
+ (synopsis "Simons Observatory N(ell) noise models")
+ (description
+ "This package provides N(ell) noise curve projection code for the
+Simons Observatory. The intention is that the full history of noise models
+will be provided to supplement published projections and simulations.")
+ (license license:bsd-2))))
+
(define-public python-soxs
(package
(name "python-soxs")