summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Kehayias <[email protected]>2025-01-30 23:24:18 -0500
committerJohn Kehayias <[email protected]>2025-01-30 23:28:09 -0500
commit7e6696908e2361582c4d4139d75ee0ed0bdc115c (patch)
tree361c355ad3758c09143f43977f4bd6cdb8c51195 /gnu
parente54b4895b7f08e768308c9253214f63a61594aa0 (diff)
gnu: hyprland: Fix xwayland and hyprland-qtutils paths.
* gnu/packages/wm.scm (hyprland):[arguments]<#:phases>: Update fix-path phase to match upstream changes. Change-Id: Iee70c589b9f408253ac06b6b7c852609d6d34e25
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 47f9119ac0..92471268f3 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -400,8 +400,9 @@ commands (lock/unlock/before-sleep) and inhibit.")
(search-input-file
inputs (string-append "bin/" cmd))))
(substitute* '("src/Compositor.cpp"
+ "src/xwayland/XWayland.cpp"
"src/managers/VersionKeeperManager.cpp")
- (("!executableExistsInPath.*\".") "false")
+ (("!NFsUtils::executableExistsInPath.*\".") "false")
(("hyprland-update-screen" cmd)
(search-input-file inputs (in-vicinity "bin" cmd)))))))))
(native-inputs