summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHilton Chain <[email protected]>2025-01-30 15:40:11 +0800
committerHilton Chain <[email protected]>2025-01-30 20:15:46 +0800
commit41ab2ddd9bb5d19ece219d9f175f5215f09a7fb1 (patch)
treef585e16fc7c9de10dd688b7bec7dc2c5ae22893f /gnu
parentc994e9262f9dbe4d688f688c92aedb3ee7ba4dfc (diff)
gnu: qtile: Fix package definition.
This is a follow-up to cfc9e96381edd973c8b7de8f2b489eb5c8fab82c, quoting the #:test-flags argument properly. * gnu/packages/wm.scm (qtile)[arguments]<#:test-flags>: Use gexp. [native-inputs]: Add python-setuptools, python-wheel. Change-Id: I6d9d788df193b05ea3331c0bc8504e3fd5fe1311 Fixes: https://issues.guix.gnu.org/75915 Reported-by: Orahcio Felicio de Sousa <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 0d4f7860c6..47f9119ac0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -813,7 +813,8 @@ subscribe to events.")
(list
;; A lot of tests fail despite Xvfb and writable temp/cache space.
#:tests? #f
- #:test-flags '("--ignore=test/widgets/test_widget_init_configure.py")
+ #:test-flags
+ #~(list "--ignore=test/widgets/test_widget_init_configure.py")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-paths
@@ -865,7 +866,9 @@ subscribe to events.")
python-pytest
python-pytest-cov
python-psutil
+ python-setuptools
python-setuptools-scm
+ python-wheel
xorg-server-for-tests))
(home-page "http://qtile.org")
(synopsis "Hackable tiling window manager written and configured in Python")