summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-27 12:04:41 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:27 +0000
commit34757c63b95eed1bf0a3c5d36741b1c28df6ad69 (patch)
treee87745e11d266578cfb867fe477d3fd7566ce60a /gnu
parent614ae7bff1d6492822ffce5cead83d98e34ca430 (diff)
gnu: Add go-github-com-beevik-ntp.
* gnu/packages/golang-web.scm (go-github-com-beevik-ntp): New variable. Change-Id: I4f43146da02860dde9a3c969810968c91e546759
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index a07deb2b82..c7c051c809 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -693,6 +693,37 @@ credentials sources.")
Manager,NTLM}/Negotiate authentication over HTTP.")
(license license:expat)))
+(define-public go-github-com-beevik-ntp
+ (package
+ (name "go-github-com-beevik-ntp")
+ (version "1.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/beevik/ntp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n2mr4nnbsv5f0w3hkk3kmyn3wd2xqi5zxgcm8s50fdizk0nqmi9"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/beevik/ntp"
+ ;; Tests requir access to <0.beevik-ntp.pool.ntp.org:53>.
+ #:test-flags #~(list "-skip" "TestOnlineQuery|TestOnlineTime")))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-golang-org-x-net))
+ (home-page "https://github.com/beevik/ntp")
+ (synopsis "NTP client package for Golang")
+ (description
+ "Package ntp provides an implementation of a Simple NTP (SNTP) client
+capable of querying the current time from a remote NTP server as specified in
+@url{https://rfc-editor.org/rfc/rfc5905.html, RFC 5905}.")
+ (license license:bsd-2)))
+
(define-public go-github-com-bep-golibsass
(package
(name "go-github-com-bep-golibsass")