summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <[email protected]>2023-05-13 16:36:02 +0200
committerNicolas Goaziou <[email protected]>2023-07-18 18:10:53 +0200
commitf0a491f717f5719af4ece891ca5133da6ba36adf (patch)
treeddcbf1395d59aa9704feb96acfe0f15f968cf317 /gnu/packages
parent94d0e6c56a3474fd7a389e55365c9cfc653ea12e (diff)
gnu: texlive-latex-multirow -> texlive-multirow.
* gnu/packages/tex.scm (texlive-multirow): New variable. (texlive-latex-multirow): Deprecate variable. (texlive-metalogo): * gnu/packages/docbook.scm (dblatex): * gnu/packages/maths.scm (hypre): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/tex.scm33
3 files changed, 20 insertions, 17 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index b214dbc9df..bc576217e5 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -548,7 +548,7 @@ the in DocBook SGML DTDs.")
texlive-hyperref
texlive-jknapltx
texlive-listings
- texlive-latex-multirow
+ texlive-multirow
texlive-latex-overpic
texlive-pdfpages
texlive-refcount
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index af8efd3ca3..7a98c05e29 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5806,7 +5806,7 @@ set.")
texlive-geometry
texlive-hanging
texlive-hyperref
- texlive-latex-multirow
+ texlive-multirow
texlive-natbib
texlive-latex-needspace
texlive-newunicodechar
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 70d0c3804b..485d6cfe58 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6189,7 +6189,7 @@ output routine.")
texlive-latex-base
texlive-latex-eukdate
texlive-graphics
- texlive-latex-multirow
+ texlive-multirow
texlive-lm ;for lmroman10-regular
texlive-stix2-otf))
(propagated-inputs (list texlive-fontspec texlive-iftex
@@ -7363,27 +7363,30 @@ on the loop variable, so that the package is equally applicable in graphics
applications like PSTricks as it is with the more common integer loops.")
(license license:lppl)))
-(define-public texlive-latex-multirow
+(define-public texlive-multirow
(package
- (name "texlive-latex-multirow")
+ (name "texlive-multirow")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "multirow"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1kak9i6nwz6vc4xjj6lbvkb69s49pis6qynjzvsjraxbdw28y2dq"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/multirow/"
+ "source/latex/multirow/"
+ "tex/latex/multirow/")
+ (base32
+ "18xnxqbkkzblngws1ydmkiwfrf9gvrriqrjpb6g6kmaxciwypqd6")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/multirow"))
- (home-page "https://www.ctan.org/pkg/multirow")
+ (home-page "https://ctan.org/pkg/multirow")
(synopsis "Create tabular cells spanning multiple rows")
(description
- "The package provides tools for creating tabular cells spanning multiple
-rows. It has a lot of flexibility, including an option for specifying an
-entry at the \"natural\" width of its text.")
+ "The package has a lot of flexibility, including an option for specifying
+an entry at the natural width of its text. The package is distributed with
+the @code{bigdelim} and @code{bigstrut} packages, which can be used to
+advantage with @code{\\multirow} cells.")
(license license:lppl1.3+)))
+(define-deprecated-package texlive-latex-multirow texlive-multirow)
+
(define-public texlive-latex-overpic
(package
(name "texlive-latex-overpic")