summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRoman Scherer <[email protected]>2024-12-29 13:14:34 +0100
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:45 +0000
commit24c8a97c3cd024c8f76209a25d44e5f5aeaeae2b (patch)
treecbcdca26dfd0d9827c457adaf76c0688dcaaf923 /gnu/packages
parent4aa828cabed99dcbe6e614579c4c486491b31aa5 (diff)
gnu: Add go-github-com-yudai-gojsondiff.
* gnu/packages/golang-xyz.scm (go-github-com-yudai-gojsondiff): New variable. Change-Id: I26c56581e3d181d8657ed50f9ba43ca84225cd7e Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 508a62e4ec..9a444ec68f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -12832,6 +12832,40 @@ detection.")
@url{https://github.com/yosuke-furukawa/json5, JSON5}.")
(license license:bsd-3))))
+(define-public go-github-com-yudai-gojsondiff
+ (package
+ (name "go-github-com-yudai-gojsondiff")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yudai/gojsondiff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qnymi0027mb8kxm24mmd22bvjrdkc56c7f4q3lbdf93x1vxbbc2"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (delete-file-recursively "vendor")))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/yudai/gojsondiff"
+ #:test-subdirs #~(list "formatter/...")))
+ (native-inputs
+ (list go-github-com-onsi-ginkgo))
+ (propagated-inputs
+ (list go-github-com-sergi-go-diff
+ go-github-com-yudai-golcs))
+ (home-page "https://github.com/yudai/gojsondiff")
+ (synopsis "JSON Diff and Patch for Golang")
+ (description
+ "This package implements a \"diff\" algorithm that compares two JSON
+objects and generates deltas that describe the differences between them. The
+deltas can be applied to a JSON object to \"patch\" them.")
+ (license license:expat)))
+
(define-public go-github-com-yudai-golcs
(package
(name "go-github-com-yudai-golcs")