summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 13:30:54 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:34 +0800
commitb50c64b5e552c0f24558acb217a69b9a2c0c68f7 (patch)
tree120cb4ed8263fd09a38e87e02c6e4dea54d5cd04 /gnu/packages/xfce.scm
parent51259f7108c9e49b15ab5fbc90c01ace11db7344 (diff)
gnu: xfce4-cpugraph-plugin: Update to 1.2.11.
* gnu/packages/xfce.scm (xfce4-cpugraph-plugin): Update to 1.2.11. [source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: I5038adfe88af206235605250efa32d73890623bb
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index bbc2f90195..666807d291 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1685,24 +1685,24 @@ A plugin for the Xfce panel is also available.")
(define-public xfce4-cpugraph-plugin
(package
- (name "xfce4-cpugraph-plugin")
- (version "1.2.10")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
- "xfce4-cpugraph-plugin/"
- (version-major+minor version)
- "/xfce4-cpugraph-plugin-" version ".tar.bz2"))
- (sha256
- (base32
- "05frfn3y009xndks9rsw90jgk0v5zfarn5jqaqci45v9ab82sy9p"))))
+ (name "xfce4-cpugraph-plugin")
+ (version "1.2.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/panel-plugins/"
+ name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z3vbpn6ylx32fnncswi0ghp01bpxqvs0idmr8fc3rl546pgmqa3"))))
(build-system gnu-build-system)
(native-inputs
- (list intltool pkg-config))
+ (list xfce4-dev-tools))
(inputs
(list libxfce4ui xfce4-panel))
- (home-page
- "https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin")
+ (home-page "https://docs.xfce.org/panel-plugins/xfce4-cpugraph-plugin/")
(synopsis "Display CPU load as a graph in the Xfce panel")
(description "This panel plugin offers multiple display
modes (LED, gradient, fire, etc…) to show the current CPU load of the