summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 11:21:22 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:33 +0800
commit4e60dd9c459abc3ef3ecc50221200f454c38c583 (patch)
tree5c33845dd995143f86397edde6eb52e82b83317a /gnu/packages/xfce.scm
parent95dbe5e9601c566993da933861d1515389d08003 (diff)
gnu: thunar-media-tags-plugin: Update to 0.5.0.
* gnu/packages/xfce.scm (thunar-media-tags-plugin): Update to 0.5.0. [source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: I82fe726d536536cdf3f9b062a64e66248a85c858
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 1424fd8893..a64b5b923d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -902,19 +902,21 @@ Samba from Thunar (the Xfce file manager) without requiring root access.")
(define-public thunar-media-tags-plugin
(package
(name "thunar-media-tags-plugin")
- (version "0.4.0")
+ (version "0.5.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/thunar-plugins/"
- name "/" (version-major+minor version)
- "/" name "-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/thunar-plugins/"
+ name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "02n99ymqs8msa798r63sy409pwrycg8p4pxx3yf497k924g134lm"))))
+ (base32 "091i975aazkhkxyh0h0msyqkkr1z2dfy068syaawcisyaw1h2mpg"))))
(build-system gnu-build-system)
- (native-inputs (list pkg-config intltool))
+ (native-inputs (list xfce4-dev-tools))
(inputs (list exo gtk+ thunar taglib))
- (home-page "https://www.xfce.org/")
+ (home-page "https://docs.xfce.org/xfce/thunar/media-tags")
(synopsis "Media tags plugin for Thunar file manager")
(description
"Media tags plugin allows tags editing from Thunar file manager and