summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 13:36:49 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:34 +0800
commit432ba602ddf8f88feefc816e502741aa9be8a674 (patch)
tree23f17e97a037ac7fc244455e287fe2a391198b7d /gnu/packages/xfce.scm
parent6bfa202069747e23dafdec544f63290d120b7812 (diff)
gnu: xfce4-datetime-plugin: Switch to git source.
* gnu/packages/xfce.scm (xfce4-datetime-plugin)[source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: If75be225349b366f1e94b0361e68a3705bd35b2a
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a870dcdce0..e92317ca6a 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1741,24 +1741,24 @@ watch your every step.")
(define-public xfce4-datetime-plugin
(package
- (name "xfce4-datetime-plugin")
- (version "0.8.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
- "xfce4-datetime-plugin/"
- (version-major+minor version)
- "/xfce4-datetime-plugin-" version ".tar.bz2"))
- (sha256
- (base32
- "1c00rj3h25g0g3ss5n07hp2ziis3rnjd5jr6firnhs2qzdwynbkb"))))
+ (name "xfce4-datetime-plugin")
+ (version "0.8.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/panel-plugins/"
+ name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qkaz932qrkbajicd8h8ik405804xvaz1bqf36sh73nmvrj7k4vn"))))
(build-system gnu-build-system)
(native-inputs
- (list intltool pkg-config))
+ (list xfce4-dev-tools))
(inputs
(list libxfce4ui xfce4-panel))
- (home-page
- "https://goodies.xfce.org/projects/panel-plugins/xfce4-datetime-plugin")
+ (home-page "https://docs.xfce.org/panel-plugins/xfce4-datetime-plugin/")
(synopsis "Display date and time inside the Xfce panel")
(description "This plugin shows the date and time in the panel,
and a calendar appears when you left-click on it.")