summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 12:18:09 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:33 +0800
commit379039d26e971df6e0ed0701d3fb70cb51f0985c (patch)
tree7908a0bf96e6bf24c661c914b167a791ad92e1bb /gnu/packages/xfce.scm
parenta4dc9c3ccd0348557eb1b94fb715f34081c9da65 (diff)
gnu: xfce4-power-manager: Switch to git source.
* gnu/packages/xfce.scm (xfce4-power-manager)[source]: Switch to git-fetch. [arguments]: Add "--enable-maintainer-mode" to configure-flags. Remove 'patch-configure phase. [native-inputs]: Add xfce4-dev-tools. [inputs]: Add wlr-protocols. [home-page]: Set to docs.xfce.org. Change-Id: Ief7a7b05516ad535f4417aa4f927bca6d039e034
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm34
1 files changed, 15 insertions, 19 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 6a2c6c905d..a35ba85661 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1358,29 +1358,25 @@ system resources, while still being visually appealing and user friendly.")
(package
(name "xfce4-power-manager")
(version "4.20.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/xfce/"
- "xfce4-power-manager/" (version-major+minor version) "/"
- "xfce4-power-manager-" version ".tar.bz2"))
- (sha256
- (base32
- "0agdsq2d4kr9aw7nqj1x5cgpxqcjffajipwjvlxq6likyv7924wp"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/xfce/" name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "089qv5704y5dk2jddl3rij4d591q5i2dqlv8gb6vr250pyp1v9d8"))))
(build-system gnu-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-before 'configure 'patch-configure
- (lambda _
- (substitute* "configure"
- ;; XDG_CHECK_PACKAGE_BINARY requires an absolute path.
- (("\\$PKG_CONFIG --variable=gdbus_codegen gio-2.0")
- "type -p gdbus-codegen")))))))
+ (list #:configure-flags
+ #~(list "--enable-maintainer-mode"))) ;for xfpm-dbus-marshal.h, etc.
(native-inputs
- (list (list glib "bin") pkg-config intltool))
+ (list xfce4-dev-tools))
(inputs
- (list libxrandr gtk+ upower libnotify libxfce4ui polkit xfce4-panel))
- (home-page "https://www.xfce.org/")
+ (list libxrandr gtk+ upower libnotify libxfce4ui polkit
+ wlr-protocols xfce4-panel))
+ (home-page "https://docs.xfce.org/xfce/xfce4-power-manager/")
(synopsis "Xfce Power Manager")
(description
"This is a power manager for the Xfce desktop. It manages the power