summaryrefslogtreecommitdiff
path: root/gnu/packages/wireservice.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <[email protected]>2024-12-26 10:41:07 +0100
committerGuillaume Le Vaillant <[email protected]>2024-12-29 11:33:36 +0100
commit4a4a8c9d2621d4871c4b9c8857bfb0e6e53d7e56 (patch)
tree5835eb96e70e1b45a9b925ce753b66d88c2b6f07 /gnu/packages/wireservice.scm
parent16d22911e8a6fe0b06f32c14eb0104e92d717193 (diff)
gnu: csvkit: Fix tests.
* gnu/packages/wireservice.scm (csvkit): Fix tests [source]: Apply patch. [native-inputs]: Add (libc-utf8-locales-for-target). * gnu/packages/patches/csvkit-set-locale-for-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I787c0da270fa4062491efcfa0c55a1b8bbac7b59 Signed-off-by: Guillaume Le Vaillant <[email protected]>
Diffstat (limited to 'gnu/packages/wireservice.scm')
-rw-r--r--gnu/packages/wireservice.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index df630023cf..c99bcd4524 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -217,10 +217,13 @@ for xls and xlsx files support to all @code{agate.Table} instances.")))
(uri (pypi-uri "csvkit" version))
(sha256
(base32
- "08wj0hlmbdmklar12cjzqp91vcxzwifsvmgasszas8kbiyvvgpdy"))))
+ "08wj0hlmbdmklar12cjzqp91vcxzwifsvmgasszas8kbiyvvgpdy"))
+ (patches
+ (search-patches "csvkit-set-locale-for-tests.patch"))))
(build-system python-build-system)
(native-inputs
- (list python-psycopg2 ; to test PostgreSQL support
+ (list (libc-utf8-locales-for-target)
+ python-psycopg2 ; to test PostgreSQL support
python-sphinx python-sphinx-rtd-theme))
(inputs
(list python-agate-dbf python-agate-excel python-agate-sql
@@ -234,8 +237,7 @@ for xls and xlsx files support to all @code{agate.Table} instances.")))
(man1 (string-append out "/share/man/man1")))
(with-directory-excursion "docs"
(invoke "make" "man")
- (copy-recursively "_build/man" man1))
- #t))))))
+ (copy-recursively "_build/man" man1))))))))
(home-page "https://csvkit.rtfd.org")
(synopsis "Command-line tools for working with CSV")
(description "csvkit is a suite of command-line tools for converting to