summaryrefslogtreecommitdiff
path: root/gnu/packages/wireservice.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-14 09:42:40 +0000
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:53 +0100
commit2e0990cdb446e9767b8665587c653e06e69e438f (patch)
treeee695a7324eeccd6a9636a5a5eb68f220f6dff89 /gnu/packages/wireservice.scm
parent75c286363e472bb32501b0e8e9c6b29e78e04e1e (diff)
gnu: Remove wireservice-package syntax rule.
* gnu/packages/wireservice.scm ((wireservice-package): Delete syntax rule. Change-Id: I0f0ad62e782b400bd8a8bf2856c1fa3f37cb1a33
Diffstat (limited to 'gnu/packages/wireservice.scm')
-rw-r--r--gnu/packages/wireservice.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index 34e84240cf..f4b1d14d33 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -39,34 +39,6 @@
#:use-module (gnu packages time)
#:use-module (gnu packages xml))
-;; Common package definition for packages from https://github.com/wireservice.
-(define-syntax-rule (wireservice-package extra-fields ...)
- (package
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "nosetests" "tests")))
- (add-after 'install 'install-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/"
- ,(package-name this-package)
- "-"
- ,(package-version this-package))))
- (with-directory-excursion "docs"
- (for-each
- (lambda (target)
- (invoke "make" target)
- (copy-recursively (string-append "_build/" target)
- (string-append doc "/" target)))
- '("html" "dirhtml" "singlehtml" "text")))
- #t))))))
- (license license:expat)
- extra-fields ...))
-
(define-public python-leather
(package
(name "python-leather")