summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2020-09-14 16:17:19 -0400
committerMaxim Cournoyer <[email protected]>2020-09-14 16:17:19 -0400
commitfa8fe90edb4efaf7d52f71516c4dcabb13d56418 (patch)
tree8d69a1132e95845d8a3d90f1fe4d0ef04039e2f4 /gnu/packages/wget.scm
parent1bec03df9b60f156c657a64a323ef27f4ed14b44 (diff)
parentd60739dff2e2f5eb74173b73a5fd207ef7cd110a (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index d7ac9e0c12..7950b3b729 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2017, 2018 Ludovic Courtès <[email protected]>
;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <[email protected]>
;;; Copyright © 2017 Rutger Helling <[email protected]>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -76,15 +76,15 @@ in downloaded documents to relative links.")
(define-public wgetpaste
(package
(name "wgetpaste")
- (version "2.29")
+ (version "2.30")
(source
(origin
(method url-fetch)
- (uri (string-append "http://wgetpaste.zlin.dk/wgetpaste-"
+ (uri (string-append "https://wgetpaste.zlin.dk/wgetpaste-"
version ".tar.bz2"))
(sha256
- (base32
- "1rp0wxr3zy7y2xp3azaadfghrx7g0m138f9qg6icjxkkz4vj9r22"))))
+ (base32 "14k5i6j6f34hcf9gdb9cnvfwscn0ys2dgd73ci421wj9zzqkbv73"))
+ (patches (search-patches "wgetpaste-update-bpaste.patch"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -94,12 +94,12 @@ in downloaded documents to relative links.")
(modify-phases %standard-phases
(delete 'configure)
(delete 'build)
- (add-after 'unpack 'remove-dead-paste-site
- ;; This phase is adaped from the following patch:
- ;; https://gitweb.gentoo.org/repo/gentoo.git/tree/app-text/wgetpaste/files/wgetpaste-remove-dead.patch
+ (add-after 'unpack 'change-unfriendly-default
(lambda _
(substitute* "wgetpaste"
- (("-bpaste") "-dpaste")) ; dpaste blocks tor users
+ ;; dpaste blocks Tor users. Use a better default.
+ (("DEFAULT_SERVICE:-dpaste")
+ "DEFAULT_SERVICE-bpaste"))
#t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
@@ -128,7 +128,7 @@ in downloaded documents to relative links.")
(inputs
`(("wget" ,wget)
("xclip" ,xclip)))
- (home-page "http://wgetpaste.zlin.dk/")
+ (home-page "https://wgetpaste.zlin.dk/")
(synopsis "Script that automates pasting to a number of pastebin services")
(description
"@code{wgetpaste} is an extremely simple command-line interface to various