summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-10-29 09:32:39 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:15:09 +0200
commit979839cf777b42675db22d4df2cb38a4b5835256 (patch)
treeeb43965528e40342bc18b5c66f25e11eb1a13353 /gnu/packages/video.scm
parent99aac5914319a70fb91fa5b153d13ad43f260cb5 (diff)
gnu: x265: Link together all library variants.
* gnu/packages/video.scm (x265)[arguments]: Adjust the 'configure-flags to link the 10bit and 12bit variants of the libraries. Adjust the 'build-12-bit and 'build-10-bit phases to not build the shared libraries. Remove 'install-more-libs phase. Change-Id: I338e9a3d216e35e6e38fe6ccfd29236d14054306 Signed-off-by: Efraim Flashner <[email protected]>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 1329092a81..2d275f0b82 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1324,8 +1324,11 @@ on the Invidious instances only as a fallback method.")
(arguments
`(#:tests? #f ; tests are skipped if ENABLE_ASSEMBLY is TRUE.
#:configure-flags
- ;; Ensure position independent code for everyone.
(list "-DENABLE_PIC=TRUE"
+ "-DLINKED_10BIT=ON"
+ "-DLINKED_12BIT=ON"
+ "-DEXTRA_LIB=x265_main10.a;x265_main12.a"
+ "-DEXTRA_LINK_FLAGS=-L../build-10bit -L../build-12bit"
(string-append "-DCMAKE_INSTALL_PREFIX="
(assoc-ref %outputs "out")))
#:phases
@@ -1344,7 +1347,7 @@ on the Invidious instances only as a fallback method.")
(lambda* (#:key (configure-flags '()) #:allow-other-keys #:rest args)
(mkdir "../build-12bit")
(with-directory-excursion "../build-12bit"
- (apply invoke
+ (invoke
"cmake" "../source"
,@(if (target-aarch64?)
'("-DENABLE_ASSEMBLY=OFF")
@@ -1356,8 +1359,9 @@ on the Invidious instances only as a fallback method.")
"-DHIGH_BIT_DEPTH=ON"
"-DEXPORT_C_API=OFF"
"-DENABLE_CLI=OFF"
- "-DMAIN12=ON"
- configure-flags)
+ "-DENABLE_SHARED=OFF"
+ "-DENABLE_PIC=TRUE"
+ "-DMAIN12=ON")
(substitute* (cons "cmake_install.cmake"
(append
(find-files "CMakeFiles/x265-shared.dir")
@@ -1368,7 +1372,7 @@ on the Invidious instances only as a fallback method.")
(lambda* (#:key (configure-flags '()) #:allow-other-keys #:rest args)
(mkdir "../build-10bit")
(with-directory-excursion "../build-10bit"
- (apply invoke
+ (invoke
"cmake" "../source"
,@(if (target-aarch64?)
'("-DENABLE_ASSEMBLY=OFF")
@@ -1380,19 +1384,14 @@ on the Invidious instances only as a fallback method.")
"-DHIGH_BIT_DEPTH=ON"
"-DEXPORT_C_API=OFF"
"-DENABLE_CLI=OFF"
- configure-flags)
+ "-DENABLE_SHARED=OFF"
+ "-DENABLE_PIC=TRUE")
(substitute* (cons "cmake_install.cmake"
(append
(find-files "CMakeFiles/x265-shared.dir")
(find-files "CMakeFiles/x265-static.dir")))
(("libx265") "libx265_main10"))
((assoc-ref %standard-phases 'build)))))
- (add-after 'install 'install-more-libs
- (lambda args
- (with-directory-excursion "../build-12bit"
- ((assoc-ref %standard-phases 'install)))
- (with-directory-excursion "../build-10bit"
- ((assoc-ref %standard-phases 'install)))))
(add-before 'strip 'move-static-libs
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))