summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorChristopher Baines <[email protected]>2023-03-02 10:37:28 +0000
committerChristopher Baines <[email protected]>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/textutils.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 151add964e..e5d3a0efc0 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -79,25 +79,24 @@
(define-public dos2unix
(package
(name "dos2unix")
- (version "7.4.3")
+ (version "7.4.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://waterlan.home.xs4all.nl/dos2unix/"
"dos2unix-" version ".tar.gz"))
(sha256
- (base32 "0wnacvz99rnlx0ayf5jrxwljvh801r8k1ai3hj137yfsaqcv93dn"))))
+ (base32 "0vj3wix17vl7a85hg673qqyrhw9sbq0xiadbbij7v0nm1gdl3a18"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "prefix=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("perl" ,perl)))
+ (list gettext-minimal perl))
(home-page "https://waterlan.home.xs4all.nl/dos2unix.html")
(synopsis "DOS/Mac to Unix and vice versa text file format converter")
(description
@@ -852,7 +851,7 @@ categories.")
(invoke "sh" "test_all.sh")))))))))
(native-inputs (list which)) ;for tests
(inputs (list pcre))
- (home-page "http://drmtools.sourceforge.net/")
+ (home-page "https://drmtools.sourceforge.net/")
(synopsis "Utilities to manipulate text and binary files")
(description "The drm_tools package contains the following commands:
@table @command
@@ -1082,7 +1081,7 @@ names like Euro.
@item Handling (bullet, decimal, letter, roman) lists along with (attempt at)
indentation.
@end itemize\n")
- (home-page "http://docx2txt.sourceforge.net")
+ (home-page "https://docx2txt.sourceforge.net")
(license license:gpl3+)))
(define-public html2text