summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2022-01-25 22:07:13 -0500
committerMaxim Cournoyer <[email protected]>2022-01-25 22:07:13 -0500
commit1a5302435ff0d2822b823f5a6fe01faa7a85c629 (patch)
treeac7810c88b560532f22d2bab2e59609cd7305c21 /gnu/packages/tcl.scm
parent3ff2ac4980dacf10087e4b42bd9fbc490591900c (diff)
parent070b8a893febd6e7d8b2b7c8c4dcebacf7845aa9 (diff)
Merge branch 'master' into staging.
With "conflicts" solved (all in favor of master except git) in: gnu/local.mk gnu/packages/databases.scm gnu/packages/glib.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/linux.scm gnu/packages/machine-learning.scm gnu/packages/networking.scm gnu/packages/polkit.scm gnu/packages/pulseaudio.scm gnu/packages/rpc.scm gnu/packages/rust.scm gnu/packages/version-control.scm gnu/packages/w3m.scm
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm154
1 files changed, 68 insertions, 86 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 55a95792cb..810095282e 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2018 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Jan Nieuwenhuizen <[email protected]>
;;; Copyright © 2017 Kei Kebreau <[email protected]>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019 Julien Lepiller <[email protected]>
;;; Copyright © 2019 Mathieu Othacehe <[email protected]>
;;;
@@ -25,6 +25,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages tcl)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -44,20 +45,19 @@
(define-public tcl
(package
(name "tcl")
- (version "8.6.10")
+ (version "8.6.11")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
version "/tcl" version "-src.tar.gz"))
(sha256
(base32
- "1vc7imilx6kcb5319r7hnrp4jn5pqb41an3vr3azhgcfcgvdp5ji"))
- (patches (search-patches "tcl-fix-cross-compilation.patch"))))
+ "0n4211j80mxr6ql0xx52rig8r885rcbminfpjdb2qrw6hmk8c14c"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-before 'configure 'pre-configure
- (lambda _ (chdir "unix") #t))
+ (lambda _ (chdir "unix")))
(add-after 'install 'install-private-headers
(lambda* (#:key outputs #:allow-other-keys)
;; Private headers are needed by Expect.
@@ -68,8 +68,7 @@
;; Programs such as Ghostscript rely on it.
(with-directory-excursion bin
(symlink (car (find-files "." "tclsh"))
- "tclsh"))
- #t))))
+ "tclsh"))))))
;; By default, man pages are put in PREFIX/man, but we want them in
;; PREFIX/share/man. The 'validate-documentation-location' phase is
@@ -98,7 +97,7 @@
(define-public itcl
(package
(name "itcl")
- (version "4.2.0")
+ (version "4.2.2")
(source
(origin
(method url-fetch)
@@ -107,37 +106,33 @@
version "/itcl" version ".tar.gz"))
(file-name (string-append "incrtcl-" version ".tar.gz"))
(sha256
- (base32 "0w28v0zaraxcq1s9pa6cihqqwqvvwfgz275lks7w4gl7hxjxmasw"))))
+ (base32 "0v0m1s3rlsbg7p366i6m5zcvnmixnch87jmczidjanqvmw76fk5c"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- (list
- (string-append
- "--exec-prefix=" (assoc-ref %outputs "out"))
- (string-append
- "--with-tclinclude=" (assoc-ref %build-inputs "tcl") "/include")
- (string-append
- "--with-tcl=" (assoc-ref %build-inputs "tcl") "/lib"))
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'cleanup-bin-and-lib
- (lambda* (#:key outputs #:allow-other-keys)
- ;; NOTE: (Sharlatan-20210213T204336+0000): libraries appearer in
- ;; "out/lib/itcl{{version}}" and there are no binaries, some extra
- ;; rename and remove spells are to be applied.
- (let ((out (assoc-ref outputs "out")))
- (rmdir
- (string-append out "/bin"))
- (rename-file
- (string-append out "/lib/itcl" ,version) (string-append out "/libtmp"))
- (rename-file
- (string-append out "/libtmp") (string-append out "/lib")))
- #t)))))
+ (list #:configure-flags
+ #~(list
+ (string-append "--exec-prefix=" #$output)
+ (string-append "--with-tclinclude="
+ (assoc-ref %build-inputs "tcl") "/include")
+ (string-append "--with-tcl="
+ (assoc-ref %build-inputs "tcl") "/lib"))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'clean-up-bin-and-lib
+ (lambda _
+ ;; NOTE: (Sharlatan-20210213T204336+0000): libraries appearer in
+ ;; "out/lib/itcl{{version}}" and there are no binaries, some extra
+ ;; rename and remove spells are to be applied.
+ (rmdir (string-append #$output "/bin"))
+ (rename-file (string-append #$output "/lib/itcl" #$version)
+ (string-append #$output "/libtmp"))
+ (rename-file (string-append #$output "/libtmp")
+ (string-append #$output "/lib")))))))
(native-inputs
- `(("tcl" ,tcl)))
+ (list tcl))
(inputs
- `(("tcllib" ,tcllib)))
+ (list tcllib))
(home-page "http://incrtcl.sourceforge.net/")
(synopsis "Object Oriented programming (OOP) extension for Tcl")
(description
@@ -160,11 +155,11 @@ multiple inheritance and public and private classes and variables.")
"0d1cp5hggjl93xwc8h1y6adbnrvpkk0ywkd00inz9ndxn21xm9s9"))))
(build-system gnu-build-system)
(inputs
- `(;; TODO: Add these optional dependencies.
- ;; ("libX11" ,libX11)
- ;; ("xorgproto" ,xorgproto)
- ;; ("tk" ,tk)
- ("tcl" ,tcl)))
+ (list ;; TODO: Add these optional dependencies.
+ ;; ("libX11" ,libX11)
+ ;; ("xorgproto" ,xorgproto)
+ ;; ("tk" ,tk)
+ tcl))
(arguments
'(#:configure-flags
(let ((out (assoc-ref %outputs "out"))
@@ -197,7 +192,7 @@ X11 GUIs.")
(define-public tk
(package
(name "tk")
- (version "8.6.10")
+ (version "8.6.11.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
@@ -205,38 +200,31 @@ X11 GUIs.")
version "-src.tar.gz"))
(sha256
(base32
- "11p3ycqbr5116vpaxv6fl6md6gcav1ffspgr8wrlc2lxhn543pv3"))
+ "1gh9k7l76qg9l0sb78ijw9xz4xl1af47aqbdifb6mjpf3cbsnv00"))
(patches (search-patches "tk-find-library.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (add-before
- 'configure 'pre-configure
- (lambda _
- (chdir "unix")
- #t))
- (add-after
- 'install 'create-wish-symlink
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (symlink (string-append out "/bin/wish"
- ,(version-major+minor
+ (add-before 'configure 'pre-configure
+ (lambda _ (chdir "unix")))
+ (add-after 'install 'create-wish-symlink
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (symlink (string-append out "/bin/wish"
+ ,(version-major+minor
(package-version tk)))
- (string-append out "/bin/wish")))
- #t))
- (add-after
- 'install 'add-fontconfig-flag
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Add the missing -L flag for Fontconfig in 'tk.pc' and
- ;; 'tkConfig.sh'.
- (let ((out (assoc-ref outputs "out"))
- (fontconfig (assoc-ref inputs "fontconfig")))
- (substitute* (find-files out
- "^(tkConfig\\.sh|tk\\.pc)$")
- (("-lfontconfig")
- (string-append "-L" fontconfig
- "/lib -lfontconfig")))
- #t))))
+ (string-append out "/bin/wish")))))
+ (add-after 'install 'add-fontconfig-flag
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Add the missing -L flag for Fontconfig in 'tk.pc' and
+ ;; 'tkConfig.sh'.
+ (let ((out (assoc-ref outputs "out"))
+ (fontconfig (assoc-ref inputs "fontconfig")))
+ (substitute* (find-files out
+ "^(tkConfig\\.sh|tk\\.pc)$")
+ (("-lfontconfig")
+ (string-append "-L" fontconfig
+ "/lib -lfontconfig")))))))
#:configure-flags
(list (string-append "--with-tcl="
@@ -251,13 +239,12 @@ X11 GUIs.")
;; The tests require a running X server, so we just skip them.
#:tests? #f))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
(inputs `(("libxft" ,libxft)
("fontconfig" ,fontconfig)
("tcl" ,tcl)))
;; tk.h refers to X11 headers, hence the propagation.
- (propagated-inputs `(("libx11" ,libx11)
- ("libxext" ,libxext)))
+ (propagated-inputs (list libx11 libxext))
(home-page "https://www.tcl.tk/")
(synopsis "Graphical user interface toolkit for Tcl")
@@ -269,7 +256,7 @@ interfaces (GUIs) in the Tcl language.")
(define-public perl-tk
(package
(name "perl-tk")
- (version "804.034")
+ (version "804.036")
(source (origin
(method url-fetch)
(uri (string-append
@@ -277,9 +264,9 @@ interfaces (GUIs) in the Tcl language.")
version ".tar.gz"))
(sha256
(base32
- "1qiz55dmw7hm1wgpjdzf2jffwcj0hisr3kf80qi8lli3qx2b39py"))))
+ "0pha40m97fzafjnq8vwkbi5sml6xv8jki6qi60rxrzmxlrqp5aij"))))
(build-system perl-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
(inputs `(("libx11" ,libx11)
("libpng" ,libpng)
("libjpeg" ,libjpeg-turbo)))
@@ -314,7 +301,7 @@ interfaces (GUIs) in the Tcl language.")
"173abxaazdmf210v651708ab6h7xhskvd52krxk6ifam337qgzh1"))))
(build-system gnu-build-system)
(native-inputs
- `(("tcl" ,tcl)))
+ (list tcl))
(native-search-paths
(list (search-path-specification
(variable "TCLLIBPATH")
@@ -339,10 +326,9 @@ utility functions and modules all written in high-level Tcl.")
"03y0bzgwbh7nnyqkh8n00bbkq2fyblq39s3bdb6mawna0bbn0wwg"))))
(build-system gnu-build-system)
(native-inputs
- `(("tcl" ,tcl)))
+ (list tcl))
(propagated-inputs
- `(("tcllib" ,tcllib)
- ("tk" ,tk))) ; for "wish"
+ (list tcllib tk)) ; for "wish"
(native-search-paths
(list (search-path-specification
(variable "TCLLIBPATH")
@@ -385,11 +371,9 @@ modules for Tk, all written in high-level Tcl. Examples of provided widgets:
(patches (search-patches "tclxml-3.2-install.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("tcl" ,tcl)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)))
+ (list tcl libxml2 libxslt))
(propagated-inputs
- `(("tcllib" ,tcllib))) ; uri
+ (list tcllib)) ; uri
(native-search-paths
(list (search-path-specification
(variable "TCLLIBPATH")
@@ -438,8 +422,7 @@ callback is evaluated.")
(assoc-ref %outputs "out")
"/lib"))))
(inputs
- `(("tcl" ,tcl)
- ("tk" ,tk)))
+ (list tcl tk))
(home-page "http://tclx.sourceforge.net/")
(synopsis "System programming extensions for Tcl")
(description
@@ -468,8 +451,7 @@ debugging tools.")
(arguments
`(#:import-path "github.com/nsf/gothic"))
(propagated-inputs
- `(("tk" ,tk)
- ("tcl" ,tcl)))
+ (list tk tcl))
(home-page "https://github.com/nsf/gothic")
(synopsis "Tcl/Tk Go bindings")
(description "Gothic contains Go bindings for Tcl/Tk. The package contains