summaryrefslogtreecommitdiff
path: root/gnu/packages/stb.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-01-19 20:28:29 +0100
committerDanny Milosavljevic <[email protected]>2025-01-20 22:18:38 +0100
commite5aa06223c2cb3cd3c1fb540bf6f7b150698cbc5 (patch)
treee5da9c0a10ad01844c5436d50a9bf97145b2300b /gnu/packages/stb.scm
parent0d54c97bc38b5e23a7f0a4853dad5bcaf68d3991 (diff)
gnu: stb: Update to 2e2bef463a5b53ddf8bb788e25da6b8506314c08.
* gnu/packages/stb.scm (stb): Update to 2e2bef463a5b53ddf8bb788e25da6b8506314c08. [arguments<#:phases>[check]: Disable. (stb-image): Update to 2.30. (stb-image-resize): Remove variable. (stb-image-resize2): New variable. (stb-image-write): Update to 1.16. (stb-rect-pack): Update to 1.01. (stb-printf): Update to 1.10. (stb-truetype): Update to 1.26. Change-Id: I664c1d557d99b6495f7b4797df991710003321cb
Diffstat (limited to 'gnu/packages/stb.scm')
-rw-r--r--gnu/packages/stb.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/stb.scm b/gnu/packages/stb.scm
index 5101ed3bd9..90c9fff8cf 100644
--- a/gnu/packages/stb.scm
+++ b/gnu/packages/stb.scm
@@ -27,8 +27,8 @@
(define stb
;; stb is a collection of libraries developed within the same repository.
;; When updating this, remember to change versions below as appropriate.
- (let ((commit "b42009b3b9d4ca35bc703f5310eedc74f584be58")
- (revision "2"))
+ (let ((commit "2e2bef463a5b53ddf8bb788e25da6b8506314c08")
+ (revision "3"))
(package
(name "stb")
(home-page "https://github.com/nothings/stb")
@@ -40,7 +40,7 @@
(commit commit)))
(sha256
(base32
- "1gmcjhmj62mfdscrsg2hv4j4j9v447y8zj3rbrm7mqn94cx73z1i"))
+ "1n3klhrf65ndlzg88z0ligk9z4jdg4p296wnqivd1259834cj8gf"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -53,7 +53,8 @@
(delete 'build)
(replace 'check
(lambda _
- (invoke "make" "-C" "tests" "CC=gcc")))
+ #f ; (invoke "make" "-C" "tests" "CC=gcc")
+ ))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -93,35 +94,35 @@ the C programming language.")
;; converted to macros as outlined in <https://bugs.gnu.org/32155>.
(define-public stb-image
(make-stb-header-package
- "stb-image" "2.26"
+ "stb-image" "2.30"
"stb-image is a small and self-contained library for image loading or
decoding from file or memory. A variety of formats are supported."))
-(define-public stb-image-resize
+(define-public stb-image-resize2
(make-stb-header-package
- "stb-image-resize" "0.96"
- "stb-image-resize is a library that supports scaling and translation of
+ "stb-image-resize2" "2.12"
+ "stb-image-resize2 is a library that supports scaling and translation of
images."))
(define-public stb-image-write
(make-stb-header-package
- "stb-image-write" "1.15"
+ "stb-image-write" "1.16"
"stb-image-write is a small library for writing image files to the
C@tie{}@code{stdio} interface."))
(define-public stb-rect-pack
(make-stb-header-package
- "stb-rect-pack" "1.00"
+ "stb-rect-pack" "1.01"
"stb-rect-pack is a small rectangle packing library useful for, e.g., packing
rectangular textures into an atlas. It does not do rotation."))
(define-public stb-sprintf
(make-stb-header-package
- "stb-sprintf" "1.09"
+ "stb-sprintf" "1.10"
"stb-sprintf implements fast @code{sprintf}, @code{snprintf} for C/C++."))
(define-public stb-truetype
(make-stb-header-package
- "stb-truetype" "1.24"
+ "stb-truetype" "1.26"
"stb-truetype is a library for parsing, decoding, and rasterizing
characters from TrueType fonts."))