summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-01-25 14:31:22 +0100
committerDanny Milosavljevic <[email protected]>2025-01-25 17:24:11 +0100
commitef7019e54802942de4880ba6400ebda8e49b2c84 (patch)
tree896037034d9b1e441dc79add49b58a7d2fe98d8b /gnu/packages/python-xyz.scm
parent781945784e40422dc96214e72ca67a92cab2e6f6 (diff)
gnu: Add python-bleak.
* gnu/packages/python-xyz.scm (python-bleak): New variable. Change-Id: Ia63bfbd6b79743a41f50cad1bdde9c586f8437cd
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b5cf77698a..41d1f11399 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -38883,6 +38883,30 @@ Currently, Linux is the only platform supported by this library.")
(synopsis "Faster version of dbus-next")
(description "This package provides a faster version of dbus-next.")
(license license:expat)))
+
+(define-public python-bleak
+ (package
+ (name "python-bleak")
+ (version "0.22.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bleak" version))
+ (sha256
+ (base32 "0p04kk84vjmfv2pl1lichaaq8rc9xdm9sgd5g9r5gr2pjv0w6j9i"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (propagated-inputs (list python-async-timeout
+ python-dbus-fast
+ python-typing-extensions))
+ (native-inputs (list python-poetry-core))
+ (home-page "https://github.com/hbldh/bleak")
+ (synopsis "Bluetooth Low Energy platform Agnostic Klient")
+ (description "This package provides a Bluetooth Low Energy platform-agnostic
+client library.")
+ (license license:expat)))
+
(define-public python-clrprint
(package
(name "python-clrprint")