summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-10 16:35:09 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:39 +0100
commitc33caf3bcdb8515158a8049e066a6283a5bdb2cf (patch)
tree8a06f04538b7f6d2cfd3646dbf134d80dcdc4e8d /gnu/packages/python-xyz.scm
parenta947c4ea60a256c5d07f46482ff5f58f939d94b1 (diff)
gnu: python-resolvelib: Update to 1.1.0b1.
* gnu/packages/python-xyz.scm (python-resolvelib): Update to 1.1.0b1. [build-system]: Use pyproject-build-system. [arguments]: Remove. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ida8eb599bcfc02e84fc95ac276fba4ba217a6511
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0bbbe2e834..b5c604ffe2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16780,7 +16780,7 @@ similar to the Python standard library's @code{json} module.")
(define-public python-resolvelib
(package
(name "python-resolvelib")
- (version "1.0.1")
+ (version "1.1.0b1")
(source
(origin
;; Tests are missing from the PyPI release.
@@ -16791,18 +16791,11 @@ similar to the Python standard library's @code{json} module.")
(file-name (git-file-name name version))
(sha256
(base32
- "0cvgimmfickarm4ks5gb5iply6sf6r4fr3v6zyqyqg45fsgqy753"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest")))))))
+ "0y0b4qd1aai50w33szz34kqj8ls42k9shkpp3lvy0jrvzgackp9p"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-commentjson python-packaging python-pytest))
+ (list python-commentjson python-packaging python-pytest
+ python-setuptools python-wheel))
(home-page "https://github.com/sarugaku/resolvelib")
(synopsis "Abstract dependencies resolver")
(description "The ResolveLib library provides a @code{Resolver} class that