summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-05-10 09:46:34 +0200
committerSharlatan Hellseher <[email protected]>2024-12-13 20:18:46 +0000
commit91744798ee9f54541f38dcba7658f9c137ce1039 (patch)
treebb5fa3e89cc52ca90bd0e63b614f65ec46a9e283 /gnu/packages/python-xyz.scm
parent44201dc715e83ba0b3e8cb6a0b8082cae842e19e (diff)
gnu: python-nbconvert: Update to 7.16.4.
* gnu/packages/python-xyz.scm (python-nbconvert): Update to 7.16.4. [arguments]: Adjust test flags. [native-inputs]: Add python-flaky and python-hatchling; remove python-setuptools and python-wheel. [propagated-inputs]: Remove python-entrypoints and python-testpath; add python-importlib-metadata, python-markupsafe, python-packaging, python-tinycss2, and texlive-soul. Change-Id: I03ae560aaabd6b31bb1e5794efc4636315be3989
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c8cc2e150e..c03487e41b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18125,20 +18125,19 @@ time.")
(define-public python-nbconvert
(package
(name "python-nbconvert")
- (version "6.5.0")
+ (version "7.16.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "nbconvert" version))
(sha256
(base32
- "17g9xq4za7vvzml6l6d8zrzknhxsvgx02hymmsw9d1dygbi4cgi2"))))
+ "1x7pz43nhlq3hwjn7cv753gapzwav6wwb9kgr66l82kb4sx93jl6"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- '(list "--pyargs" "nbconvert"
- "-k"
+ '(list "-k"
(string-append
;; These tests require pyppeteer, not yet
;; available in Guix.
@@ -18190,29 +18189,29 @@ time.")
(inputs
(list inkscape/stable pandoc))
(native-inputs
- (list python-ipykernel
+ (list python-flaky
+ python-hatchling
+ python-ipykernel
;; Adding ipywidgets would create a cycle.
;;python-ipywidgets
- ;; XXX: Disabled, not in guix.
- ;;python-pyppeteer
python-pytest
- python-pytest-xdist
- python-setuptools
- python-wheel))
+ python-pytest-xdist))
(propagated-inputs
(list python-beautifulsoup4
python-bleach
python-defusedxml
- python-entrypoints
+ python-importlib-metadata
python-jinja2
python-jupyter-core
+ python-jupyterlab-pygments
+ python-markupsafe
python-mistune
python-nbclient
python-nbformat
+ python-packaging
python-pandocfilters
python-pygments
- python-jupyterlab-pygments
- python-testpath
+ python-tinycss2
python-traitlets
;; Required, even if [serve] is not used.
python-tornado-6
@@ -18244,6 +18243,7 @@ time.")
texlive-pdfcol
texlive-pgf
texlive-rsfs
+ texlive-soul
texlive-stringenc
texlive-tcolorbox
texlive-titling