summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <[email protected]>2024-05-10 00:53:49 +0200
committerSharlatan Hellseher <[email protected]>2024-12-13 20:18:53 +0000
commit68ecdc47b22bc802e1a5b8c090e12b6b1340916b (patch)
tree5e394a8f22e1c00a8bba286b2543494ce8bbd1ae /gnu/packages/python-xyz.scm
parentbf76343e89ba3c24f1143fe9cf7224a94ec8afe6 (diff)
gnu: python-jaraco-context: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm: (python-jaraco-context)[build-system]: Move to pyproject-build-system. (python-jaraco)[arguments]: Convert <#:phases> to <#:test-flags>. Change-Id: Ifc9b8fc4a9a6c1c2f37fd014eeee1205cd2eb2c4 Signed-off-by: Nicolas Goaziou <[email protected]>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b26342771..e406bdb634 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12219,7 +12219,7 @@ WeightedLookup: A specialized RangeMap for selecting an item by weights.
(uri (pypi-uri "jaraco.context" version))
(sha256
(base32 "0hbjm1rpxf4pzmbdp9rh3ali4zqnlcr8m97bhh1nizxvzcpxim7h"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments (list #:tests? #f))
(native-inputs (list python-setuptools-scm))
(home-page "https://github.com/jaraco/jaraco.context")
@@ -12236,14 +12236,9 @@ procedures.")
(package-arguments python-jaraco-context-bootstrap)
((#:tests? _ #f)
(not (%current-target-system)))
- ((#:phases phases #~%standard-phases)
- #~(modify-phases #$phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Do not test the myproject.toml build as it tries to pull
- ;; dependencies from the Internet.
- (invoke "pytest" "-vv" "-k" "not project"))))))))
+ ;; Do not test the myproject.toml build as it pulls dependencies.
+ ((#:test-flags test-flags '())
+ '(list "-k" "not project"))))
(native-inputs
(modify-inputs
(package-native-inputs python-jaraco-context-bootstrap)