summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-14 14:07:10 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:54 +0100
commit63787199f40106e26e90bb03d4e22a01fe599fe2 (patch)
treecc0f756dc51ed52ba697259f8949483e2e538683 /gnu/packages/python-xyz.scm
parent6e2cacf2f942c6e59b3264533981c22a940af6dc (diff)
gnu: python-rcssmin: Update to 1.2.0.
* gnu/packages/python-xyz.scm (python-rcssmin): Update to 1.2.0. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: Ie61bec0942852e53d84d85364e3e445d42bf3049
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5555067d3e..53f64edb6f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24734,21 +24734,16 @@ the network.")
(define-public python-rcssmin
(package
(name "python-rcssmin")
- (version "1.0.6")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rcssmin" version))
(sha256
(base32
- "0w42l4dhxghcz7pj3q7hkxp015mvb8z2cq9sfxbl31npsfavd1ya"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "python" "run_tests.py" "tests"))))))
+ "0k68sw163vc36nb3nck0kwwal4vb4hi6634rzx7z19ng28j8fdpl"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(home-page "http://opensource.perlig.de/rcssmin/")
(synopsis "CSS Minifier")
(description "The minifier is based on the semantics of the YUI compressor,