summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 09:36:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:39 +0000
commit4d77076ceddbb5f607d9a515039c83de72f006cd (patch)
treed982a3aadacc2cfe4f891497739999465a6a8a41 /gnu/packages/python-xyz.scm
parent0df28169f34ab6b82df88c5e3a633ce30320a0fd (diff)
gnu: python-flake8-print: Update to 5.0.0.
* gnu/packages/python-xyz.scm (python-flake8-print): Update to 5.0.0. [build-system]: Swap to pyrpoject-build-system. [arguments]<tests?>: Explicitly disable them as no provided in PyPI archive or Git checkout. [propagated-inputs]: Remove python-six. [native-inputs]: Add python-poetry-core. Change-Id: Ifd52bbde3b41165d0f336973cb2817924f209568
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a69f671de1..5826158891 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15442,16 +15442,22 @@ unnecessary plus operators for explicit string literal concatenation.")
(define-public python-flake8-print
(package
(name "python-flake8-print")
- (version "4.0.0")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "flake8-print" version))
(sha256
- (base32 "05k5kkvyk6fdmvnacxfzypk74vbl3pmva13dqg1aljfwnxsc7yjs"))))
- (build-system python-build-system)
+ (base32 "1ydx92xck090ajp8vk2378fm0f4wj3mikhinjs3w1hcw70m5m4bn"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ; no tests in PiPY or git checkout
+ (native-inputs
+ (list python-poetry-core))
(propagated-inputs
- (list python-flake8 python-pycodestyle python-six))
+ (list python-flake8
+ python-pycodestyle))
(home-page "https://github.com/jbkahn/flake8-print")
(synopsis "Print statement checker plugin for Flake8")
(description