summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-14 19:24:35 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:56 +0100
commit0a8f423124a5c747313f533a758fe0c4df55fc10 (patch)
treeaccafe613f14e084019ce546719fed22ad61ce2c /gnu/packages/python-xyz.scm
parent56eab10bc0d10956e4004242d2f903683ae10695 (diff)
gnu: python-automat: Update to 24.8.1.
* gnu/packages/python-xyz.scm (python-automat): Update to 24.8.1. [arguments]: Enable tests; adjust 'remove-entrypoint. [native-inputs]: Add python-pytest; remove python-graphviz. [propagated-inputs]: Add python-graphviz and python-typing-extensions; remove python-six and python-attrs. Change-Id: Ic77e57da21590435ecfde8d9921ce6ec36576d67
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 16 insertions, 19 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a7d9ea0b06..0220c858c8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25405,34 +25405,31 @@ manipulation and interaction with formal grammars.")
(define-public python-automat
(package
(name "python-automat")
- (version "22.10.0")
+ (version "24.8.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "Automat" version))
(sha256
(base32
- "0kmh9fwb6rkh8r5bi5jyxysywpgpjnwdks1h3p0xq6ddxn2fnsz5"))))
+ "123d63k8wg9pfv9j7hr0kd1kw23m0rwdx7irsa55ncpncg7jfhmk"))))
(build-system pyproject-build-system)
- ;; We disable the tests because they require python-twisted, while
- ;; python-twisted depends on python-automat. Twisted is optional, but the
- ;; tests fail if it is not available. Also see
- ;; <https://github.com/glyph/automat/issues/71>.
(arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; Remove script, because it depends on python-twisted.
- (add-after 'unpack 'remove-entrypoint
- (lambda _
- (substitute* "setup.py"
- (("\"automat-visualize = automat._visualize:tool\"") "")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
+ (with-directory-excursion #$output
+ (apply invoke "pytest" "-vv" test-flags))))
+ ;; Remove script, because it depends on python-twisted.
+ (add-after 'unpack 'remove-entrypoint
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("automat-visualize = \"automat._visualize:tool\"") "")))))))
(native-inputs
- (list python-graphviz
- python-setuptools
- python-setuptools-scm
- python-wheel))
+ (list python-pytest python-setuptools python-setuptools-scm python-wheel))
(propagated-inputs
- (list python-six python-attrs))
+ (list python-graphviz python-typing-extensions))
(home-page "https://github.com/glyph/Automat")
(synopsis "Self-service finite-state machines")
(description "Automat is a library for concise, idiomatic Python