summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-01 21:32:31 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:29 +0100
commitebfd6af972d853eb447f0e4d5d60f598503fc82f (patch)
treeff01f016d32dcab05bae7daf72e1bce434e8e210 /gnu/packages/python-web.scm
parentf2a78678d0e322ba3aa9c901758dbfd372d47351 (diff)
gnu: python-yarl: Update to 1.18.3.
* gnu/packages/python-web.scm (python-yarl): Update to 1.18.3. [source]: Remove snippet. [build-system]: Use pyproject-build-system. [arguments]: Enable tests; delete custom 'check phase; remove phase 'cythonize-code; add phase 'patch-build-system. [native-inputs]: Remove python-cython and python-pytest-runner; add python-covdefaults, python-cython-3, python-expandvars, python-pytest-cov, python-pytest-xdist, python-setuptools, python-tomli, and python-wheel. [propagated-inputs]: Add python-packaging and python-propcache. Change-Id: Iab46d2600782ffee6fdf0c9816b771c0884af04a
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm51
1 files changed, 26 insertions, 25 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 099881d601..6f569fcfdf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6108,37 +6108,38 @@ name resolutions asynchronously.")
(define-public python-yarl
(package
(name "python-yarl")
- (version "1.6.3")
+ (version "1.18.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "yarl" version))
(sha256
(base32
- "045z4ssg8g5h0qhz8hnx74hswgkndaldqq1xi5l1n5s0j996d44a"))
- (modules '((guix build utils)))
- (snippet
- #~(begin
- (delete-file "yarl/_quoting_c.c")))))
- (build-system python-build-system)
- (arguments
- (list #:tests? #f ; test suite can't find yarl._quoting_c
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'cythonize-code
- (lambda _
- (invoke "cython" "yarl/_quoting_c.pyx")))
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (substitute* "setup.cfg"
- (("--cov=yarl") ""))
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest")))))))
- (native-inputs
- (list python-cython python-pytest python-pytest-runner))
- (propagated-inputs
- (list python-idna python-multidict))
+ "1qfj6kvdxr8bzka4lp0bh0xfgr5mzx7zzvj2jb4vcxxzbk20265c"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags '(list "--ignore-glob=tests/test_*_benchmarks.py")
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-build-system
+ (lambda _
+ ;; XXX: I don't know how to tell it to build the extensions in
+ ;; place.
+ (substitute* "packaging/pep517_backend/_backend.py"
+ (("build_inplace=False") "build_inplace=True")))))))
+ (native-inputs
+ (list python-covdefaults
+ python-cython-3
+ python-expandvars
+ python-pytest
+ python-pytest-cov
+ python-pytest-xdist
+ python-setuptools
+ python-tomli
+ python-wheel))
+ (propagated-inputs
+ (list python-packaging python-idna python-multidict python-propcache))
(home-page "https://github.com/aio-libs/yarl/")
(synopsis "Yet another URL library")
(description "@code{yarl} module provides handy @code{URL} class