summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-16 20:38:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:21 +0100
commit26e74524718ea03c340d0e2c76b1f6b89b7d86a3 (patch)
tree9f2e9aa39182bff7379fb93c45088df77a700a1b /gnu/packages/python-web.scm
parent55a5a6768ea3bb4ae498d7a52754dd100ad9fecc (diff)
gnu: Add python-legacy-cgi.
* gnu/packages/python-web.scm (python-legacy-cgi): New variable. Change-Id: I36253992291b2294896ae8c01a15f76b33615034
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 78a5fbf834..a9fb2a00bf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -310,6 +310,26 @@ scripting Launchpad via its the web service API.")
reusable library for parsing, manipulating, and generating URIs.")
(license license:lgpl3)))
+(define-public python-legacy-cgi
+ (package
+ (name "python-legacy-cgi")
+ (version "2.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "legacy_cgi" version))
+ (sha256
+ (base32 "0hksizyq7awmwh3337zy0rmj47x6b5igzam6ffj74gbwfjfakbgj"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-poetry-core python-pytest))
+ (home-page "https://github.com/jackrosenthal/legacy-cgi")
+ (synopsis "Fork of the legacy standard library cgi and cgitb modules")
+ (description
+ "This is a fork of the standard library modules @code{cgi} and
+@code{cgitb}. They are slated to be removed from the Python standard libary
+in Python 3.13 by PEP-594.")
+ (license license:psfl)))
+
(define-public python-portend
(package
(name "python-portend")