summaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-10 15:05:10 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:19:09 +0000
commitc36cc983655b7dc217a324c01e946221cdda8b15 (patch)
tree7e136dde5ee66d5c968ca5dadd0d31d82c757d16 /gnu/packages/python-build.scm
parent1b577b873462688a7ab3247f720dde25c7c5cb97 (diff)
gnu: python-exceptiongroup: Move to python-build.
* gnu/packages/python-xyz.scm (python-exceptiongroup): Move from here ... * gnu/packages/python-build.scm: ... to here. Change-Id: Id034df5a988c5f6a4448879ba44ee1315888f63b
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 9077eb854a..62fa7a65e9 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -729,6 +729,50 @@ installed, will expose packages in a local directory on @code{sys.path} in
reflected in the package visible to Python, without needing a reinstall.")
(license license:expat)))
+;; This package may be removed when we have Python 3.11 on board.
+(define-public python-exceptiongroup
+ (package
+ (name "python-exceptiongroup")
+ (version "1.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/agronholm/exceptiongroup")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wcvzwgjs0xmggs6dh92jxdqi988gafzh10hrzvw10kasy0xakfj"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:tests? #f ;TODO: Circular dependency on pytest
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: PEP 517 manual build/install procedures copied from
+ ;; python-isort.
+ (replace 'build
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)
+ ;; ZIP does not support timestamps before 1980.
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((whl (car (find-files "dist" "\\.whl$"))))
+ (invoke "pip" "--no-cache-dir" "--no-input"
+ "install" "--no-deps" "--prefix" #$output whl))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "tests")))))))
+ (native-inputs (list python-flit-scm python-pypa-build))
+ (home-page "https://github.com/agronholm/exceptiongroup")
+ (synopsis "PEP 654 backport from Python 3.11")
+ (description "This is a backport of the @code{BaseExceptionGroup} and
+@code{ExceptionGroup} classes from Python 3.11.")
+ (license license:expat)))
+
(define-public python-hatchling
(package
(name "python-hatchling")