summaryrefslogtreecommitdiff
path: root/gnu/packages/prometheus.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-27 20:43:44 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:30 +0000
commitfb0eefc221ec987ef1c008186ce9482462f84320 (patch)
tree88a5523bf1ae1e246fe75a8039d12978325083c0 /gnu/packages/prometheus.scm
parent6a54c79b3e81a2ff2d23cc4d9768e127e8faa4ab (diff)
gnu: go-github-com-prometheus-community-pro-bing: Update to 0.5.0.
* gnu/packages/prometheus.scm (go-github-com-prometheus-community-pro-bing): Update to 0.5.0. [arguments] <test-flags>: Skip one more test. Change-Id: If733e9c288d640ef412fd6932f34f2f6e42b4f4d
Diffstat (limited to 'gnu/packages/prometheus.scm')
-rw-r--r--gnu/packages/prometheus.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index dc2ac3076c..1adb42bb9a 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -378,7 +378,7 @@ from the default AWS credential chain.")
(define-public go-github-com-prometheus-community-pro-bing
(package
(name "go-github-com-prometheus-community-pro-bing")
- (version "0.4.1")
+ (version "0.5.0")
(source
(origin
(method git-fetch)
@@ -387,15 +387,19 @@ from the default AWS credential chain.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1yz4cf1qrm1jrzw2yd5p08663hynk4ihlf5mi2fn6irnzh343a7b"))))
+ (base32 "19757nqz0cpq7ir2w5xgjxpblhmkpk0j7spfw4j68agavbx6hxpm"))))
(build-system go-build-system)
(arguments
(list
- ;; Tests requiring network setup.
+ ;; Tests requiring network setup, and root access.
#:test-flags
- #~(list "-skip" (string-append "TestNewPingerValid"
- "|TestSetIPAddr"
- "|TestSetResolveTimeout"))
+ #~(list "-skip"
+ (string-join
+ (list "TestNewPingerValid"
+ "TestSetIPAddr"
+ "TestSetInterfaceName"
+ "TestSetResolveTimeout")
+ "|"))
#:import-path "github.com/prometheus-community/pro-bing"))
(propagated-inputs
(list go-github-com-google-uuid