summaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2022-01-25 22:07:13 -0500
committerMaxim Cournoyer <[email protected]>2022-01-25 22:07:13 -0500
commit1a5302435ff0d2822b823f5a6fe01faa7a85c629 (patch)
treeac7810c88b560532f22d2bab2e59609cd7305c21 /gnu/packages/parallel.scm
parent3ff2ac4980dacf10087e4b42bd9fbc490591900c (diff)
parent070b8a893febd6e7d8b2b7c8c4dcebacf7845aa9 (diff)
Merge branch 'master' into staging.
With "conflicts" solved (all in favor of master except git) in: gnu/local.mk gnu/packages/databases.scm gnu/packages/glib.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/linux.scm gnu/packages/machine-learning.scm gnu/packages/networking.scm gnu/packages/polkit.scm gnu/packages/pulseaudio.scm gnu/packages/rpc.scm gnu/packages/rust.scm gnu/packages/version-control.scm gnu/packages/w3m.scm
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm48
1 files changed, 20 insertions, 28 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 6730772f24..a6bee71aec 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2020 Eric Bavier <[email protected]>
;;; Copyright © 2015 Mark H Weaver <[email protected]>
-;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021 Efraim Flashner <[email protected]>
+;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021, 2022 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Pjotr Prins <[email protected]>
;;; Copyright © 2016 Andreas Enge <[email protected]>
;;; Copyright © 2016, 2020, 2021 Ricardo Wurmus <[email protected]>
@@ -61,14 +61,14 @@
(define-public parallel
(package
(name "parallel")
- (version "20210922")
+ (version "20220122")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/parallel/parallel-"
version ".tar.bz2"))
(sha256
- (base32 "0rjd9636sgmnhaww2q8rbnpwhpq1aqg3df6rmpdm880zqi7skp6y"))))
+ (base32 "003y6f3bidfzd2jcswl7sk3a69fnvy0pjns4v0m5gjib84hil8mq"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -82,8 +82,7 @@
;; $Global::shell = $ENV{'PARALLEL_SHELL'} ||
;; parent_shell($$) || $ENV{'SHELL'} || "/bin/sh";
(("/bin/sh\\\";\n$") (string-append (which "sh") "\";\n"))))
- (list "src/parallel" "src/sem"))
- #t))
+ (list "src/parallel" "src/sem"))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -92,8 +91,7 @@
,(map (lambda (input)
(string-append (assoc-ref inputs input) "/bin"))
'("perl"
- "procps"))))
- #t)))
+ "procps")))))))
(add-after 'wrap-program 'post-install-test
(lambda* (#:key outputs #:allow-other-keys)
(invoke (string-append
@@ -101,8 +99,7 @@
"echo"
":::" "1" "2" "3"))))))
(inputs
- `(("perl" ,perl)
- ("procps" ,procps)))
+ (list perl procps))
(home-page "https://www.gnu.org/software/parallel/")
(synopsis "Build and execute command lines in parallel")
(description
@@ -154,8 +151,7 @@ execution is also possible.")
(build-system gnu-build-system)
(arguments `(#:tests? #f)) ;; No tests
(native-inputs
- `(("flex" ,flex)
- ("which" ,which)))
+ (list flex which))
(home-page "http://www.maier-komor.de/xjobs.html")
(properties `((release-monitoring-url . ,home-page)))
(synopsis
@@ -201,13 +197,13 @@ when jobs finish.")
#t))))
;; FIXME: More optional inputs could be added,
;; in particular mysql and gtk+.
- (inputs `(("freeipmi" ,freeipmi)
- ("hwloc" ,hwloc-2 "lib")
- ("json-c" ,json-c)
- ("linux-pam" , linux-pam)
- ("munge" ,munge)
- ("numactl" ,numactl)
- ("readline" ,readline)))
+ (inputs (list freeipmi
+ `(,hwloc-2 "lib")
+ json-c
+ linux-pam
+ munge
+ numactl
+ readline))
(native-inputs
`(("autoconf" ,autoconf)
("expect" ,expect)
@@ -321,9 +317,9 @@ by managing a queue of pending work.")
(build-system gnu-build-system)
(arguments `(#:tests? #f)) ; The tests require "bats".
(inputs
- `(("slurm" ,slurm)))
+ (list slurm))
(native-inputs
- `(("which" ,which)))
+ (list which))
(home-page "https://github.com/natefoo/slurm-drmaa")
(synopsis "Distributed resource management application API for SLURM")
(description
@@ -366,10 +362,9 @@ cluster/resource management systems.")
value "\n")))
#t))))))
(inputs
- `(("slurm" ,slurm)))
+ (list slurm))
(propagated-inputs
- `(("python-ipython" ,python-ipython)
- ("python-pandas" ,python-pandas)))
+ (list python-ipython python-pandas))
(synopsis "Control the SLURM batch scheduler from Jupyter Notebook")
(description
"This package implements Jupyter/IPython
@@ -403,9 +398,7 @@ command---e.g., @code{%salloc}, @code{%sbatch}, etc.")
(build-system cmake-build-system)
(arguments '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
(inputs
- `(("googletest" ,googletest)
- ("googlebenchmark" ,googlebenchmark)
- ("fxdiv" ,fxdiv)))
+ (list googletest googlebenchmark fxdiv))
(synopsis "Efficient thread pool implementation")
(description
"The pthreadpool library implements an efficient and portable thread
@@ -434,8 +427,7 @@ features.")
(build-system cmake-build-system)
(arguments '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
(inputs
- `(("googletest" ,googletest)
- ("googlebenchmark" ,googlebenchmark)))
+ (list googletest googlebenchmark))
(synopsis "C/C++ library to obtain information about the CPU")
(description
"The cpuinfo library provides a C/C++ and a command-line interface to