summaryrefslogtreecommitdiff
path: root/gnu/packages/mastodon.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2022-01-25 22:07:13 -0500
committerMaxim Cournoyer <[email protected]>2022-01-25 22:07:13 -0500
commit1a5302435ff0d2822b823f5a6fe01faa7a85c629 (patch)
treeac7810c88b560532f22d2bab2e59609cd7305c21 /gnu/packages/mastodon.scm
parent3ff2ac4980dacf10087e4b42bd9fbc490591900c (diff)
parent070b8a893febd6e7d8b2b7c8c4dcebacf7845aa9 (diff)
Merge branch 'master' into staging.
With "conflicts" solved (all in favor of master except git) in: gnu/local.mk gnu/packages/databases.scm gnu/packages/glib.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/linux.scm gnu/packages/machine-learning.scm gnu/packages/networking.scm gnu/packages/polkit.scm gnu/packages/pulseaudio.scm gnu/packages/rpc.scm gnu/packages/rust.scm gnu/packages/version-control.scm gnu/packages/w3m.scm
Diffstat (limited to 'gnu/packages/mastodon.scm')
-rw-r--r--gnu/packages/mastodon.scm112
1 files changed, 58 insertions, 54 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index 17673c7fde..d6fd1db2b6 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019, 2020, 2021 Efraim Flashner <[email protected]>
;;; Copyright © 2019 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2021 Taiju HIGASHI <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages)
#:use-module (gnu packages check)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
@@ -40,28 +42,27 @@
(define-public toot
(package
(name "toot")
- (version "0.27.0")
+ (version "0.28.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "toot" version))
(sha256
- (base32 "1mfbqmgna7046d134pc5qx1vyfd60vwcn0xr9lxzlmc5rjdbmz8x"))))
+ (base32 "1wsj4160z3m1nvswgkl08n9ymihxhxdvxvrsycn9d3y5fplm00k9"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "py.test"))))))
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "py.test")))))))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ (list python-pytest))
(inputs
- `(("python-beautifulsoup4" ,python-beautifulsoup4)
- ("python-requests" ,python-requests)
- ("python-urwid" ,python-urwid)
- ("python-wcwidth" ,python-wcwidth)))
+ (list python-beautifulsoup4 python-requests python-urwid
+ python-wcwidth))
(home-page "https://github.com/ihabunek/toot/")
(synopsis "Mastodon CLI client")
(description "Interact with Mastodon social network from the command line.
@@ -80,15 +81,21 @@ Features include:
(name "tootle")
(version "1.0")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bleakgrey/tootle")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1nm57239mhdq462an6bnhdlijpijxmjs9mqbyirwxwa048d3n4rm"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bleakgrey/tootle")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nm57239mhdq462an6bnhdlijpijxmjs9mqbyirwxwa048d3n4rm"))
+ (patches
+ (search-patches
+ ;; https://github.com/bleakgrey/tootle/pull/339
+ "tootle-glib-object-naming.patch"
+ ;; https://github.com/bleakgrey/tootle/pull/322
+ "tootle-reason-phrase.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -98,8 +105,7 @@ Features include:
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "meson/post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-after 'unpack 'patch-source
(lambda _
(substitute* "src/Dialogs/NewAccount.vala"
@@ -108,27 +114,25 @@ Features include:
(substitute* "src/Build.vala"
(("(os_name = ).*" _ first) (string-append first "\"GNU\";\n"))
(("(os_ver = ).*" _ first) (string-append first "\"Guix\";\n"))
- (("GLib.Environment.get_os_info.*") "\"unknown\";\n"))
- #t))
+ (("GLib.Environment.get_os_info.*") "\"unknown\";\n"))))
(add-after 'install 'symlink-package
(lambda* (#:key outputs #:allow-other-keys)
(symlink "com.github.bleakgrey.tootle"
- (string-append (assoc-ref outputs "out") "/bin/tootle"))
- #t)))))
+ (string-append (assoc-ref outputs "out")
+ "/bin/tootle")))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal
+ `(,glib "bin") ; for glib-compile-resources
+ gsettings-desktop-schemas pkg-config))
(inputs
- `(("glib-networking" ,glib-networking)
- ("gtk+" ,gtk+)
- ("json-glib" ,json-glib)
- ("libgee" ,libgee)
- ("libhandy" ,libhandy)
- ("libsoup" ,libsoup)
- ("vala" ,vala-0.50)
- ("xdg-utils" ,xdg-utils)))
+ (list glib-networking
+ gtk+
+ json-glib
+ libgee
+ libhandy
+ libsoup-minimal-2
+ vala
+ xdg-utils))
(home-page "https://github.com/bleakgrey/tootle")
(synopsis "GTK3 client for Mastodon")
(description "Tootle is a GTK client for Mastodon. It provides a clean,
@@ -149,24 +153,24 @@ seamlessly with your desktop environment.")
"1vikvkzcij2gd730cssigxi38vlmzqmwdy58r3y2cwsxifnxpz9a"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-blurhash" ,python-blurhash)
- ("python-dateutil" ,python-dateutil)
- ("python-decorator" ,python-decorator)
- ("python-magic" ,python-magic)
- ("python-pytz" ,python-pytz)
- ("python-requests" ,python-requests)
- ("python-six" ,python-six)))
+ (list python-blurhash
+ python-dateutil
+ python-decorator
+ python-magic
+ python-pytz
+ python-requests
+ python-six))
(native-inputs
- `(("python-blurhash" ,python-blurhash)
- ("python-cryptography" ,python-cryptography)
- ("python-http-ece" ,python-http-ece)
- ("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)
- ("python-pytest-mock" ,python-pytest-mock)
- ("python-pytest-runner" ,python-pytest-runner)
- ("python-pytest-vcr" ,python-pytest-vcr)
- ("python-requests-mock" ,python-requests-mock)
- ("python-vcrpy" ,python-vcrpy)))
+ (list python-blurhash
+ python-cryptography
+ python-http-ece
+ python-pytest
+ python-pytest-cov
+ python-pytest-mock
+ python-pytest-runner
+ python-pytest-vcr
+ python-requests-mock
+ python-vcrpy))
(home-page "https://github.com/halcy/Mastodon.py")
(synopsis "Python wrapper for the Mastodon API")
(description