summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
author宋文武 <[email protected]>2025-01-13 16:49:51 +0800
committer宋文武 <[email protected]>2025-01-14 19:10:55 +0800
commit3f7b77472d071234808b3becaee818881fb515d7 (patch)
tree8331f8cd64b1d8cf6496cdbcfda5f2dd3c849ffa /gnu/packages/lxqt.scm
parent96f7b32d4ed439d52fb9796ef8cb138196ab91a6 (diff)
gnu: libqtxdg: Update to 4.1.0.
* gnu/packages/lxqt.scm (libqtxdg)[propagated-inputs]: Use Qt6. Move GLIB to inputs. Change-Id: I15f29c7ddeed91aebd799bbc588173051edf76f6
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 68d8c00184..b80c6f9e10 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -150,7 +150,7 @@ itself as well as other components maintained by the LXQt project.")
(define-public libqtxdg
(package
(name "libqtxdg")
- (version "3.11.0")
+ (version "4.1.0")
(source
(origin
(method url-fetch)
@@ -158,12 +158,12 @@ itself as well as other components maintained by the LXQt project.")
"https://github.com/lxqt/libqtxdg/releases/download/"
version "/libqtxdg-" version ".tar.xz"))
(sha256
- (base32 "0alphfvkwxaqfnckjxbrwjkj7wjl4yff7qxzmyjz67c8728lxbny"))))
+ (base32 "02c8irxyra0kfm7k1jkcxinfipib3w9jn2lk91hnl6jnv6bx6106"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
'("-DBUILD_TESTS=ON"
- "-DQTXDGX_ICONENGINEPLUGIN_INSTALL_PATH=lib/qt5/plugins/iconengines")
+ "-DQTXDGX_ICONENGINEPLUGIN_INSTALL_PATH=lib/qt6/plugins/iconengines")
#:phases
(modify-phases %standard-phases
(add-before 'check 'pre-check
@@ -172,10 +172,12 @@ itself as well as other components maintained by the LXQt project.")
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
(propagated-inputs
- ;; required by Qt5XdgIconLoader.pc
- (list glib qtbase-5 qtsvg-5))
+ ;; required by Qt6XdgIconLoader.pc
+ (list qtbase qtsvg))
(native-inputs
(list lxqt-build-tools pkg-config))
+ (inputs
+ (list glib))
(home-page "https://github.com/lxqt/libqtxdg")
(synopsis "Qt implementation of freedesktop.org xdg specifications")
(description "Libqtxdg implements the freedesktop.org xdg specifications