summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2024-09-20 00:16:48 +0900
committerMaxim Cournoyer <[email protected]>2024-09-20 00:20:48 +0900
commit0feeac35cb14ccfa2193c1ecbba9d0b9936d9bb6 (patch)
tree7f2a2338d1a3199640b375b97ee55f4f0b22cfe7 /gnu/packages/llvm.scm
parente85f52e826b0701c3dcf9acf9d81e5ae57aec8f9 (diff)
gnu: clang-cling-runtime: Fix build.
New patches were applied to clang-runtime only, not the whole LLVM base source, hence they were not applied to the cling variants. * gnu/packages/llvm.scm (llvm-cling) [source]: Add clang-cling-runtime-13-glibc-2.36-compat.patch and clang-cling-13-remove-crypt-interceptors.patch patches. * gnu/packages/patches/clang-cling-13-remove-crypt-interceptors.patch: New file. * gnu/packages/patches/clang-cling-runtime-13-glibc-2.36-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register them. Change-Id: I4c5ee5f65b2bc04935865ad8e67bc2c3833da2eb
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index fd2e815fe0..2ee1cf21c3 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -2301,7 +2301,10 @@ LLVM bitcode files.")
(sha256
(base32
"1zh6yp8px9hla7v9i67a6anbph140f8ixxbsz65aj7fizksjs1h3"))
- (patches (search-patches "clang-cling-13-libc-search-path.patch")))))))
+ (patches (search-patches
+ "clang-cling-13-libc-search-path.patch"
+ "clang-cling-runtime-13-glibc-2.36-compat.patch"
+ "clang-cling-13-remove-crypt-interceptors.patch")))))))
(define clang-cling-runtime
(let ((base clang-runtime-13))