summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2023-07-31 20:09:14 +0200
committerLudovic Courtès <[email protected]>2024-08-31 10:44:39 +0200
commit48ea1a2b3b8bc4c8b2247972401ab5a6f7f4ecc7 (patch)
tree46ef19732c710b7950ad9cecc7e5afdb71df4e27 /gnu/packages/java.scm
parent2f1daa35746c896cd59882383c236ee97a3cbad7 (diff)
gnu: openjdk10: Make more reproducible.
* gnu/packages/patches/openjdk-10-char-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-classlist-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-corba-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-jar-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-jtask-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-module-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-module3-reproducibility.patch: New file. * gnu/packages/patches/openjdk-10-module4-reproducibility.patch: New file. * gnu/packages/java.scm (openjdk10)[source]: Add patches. [arguments]<#:phases>[remove-timestamping]: New phase. * gnu/local.mk (dist_patch_DATA): Add patches. Signed-off-by: Maxim Cournoyer <[email protected]>
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ace06977c9..91ab61ad13 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1215,7 +1215,15 @@ new Date();"))
(base32
"0i47ar8lxzjrkkiwbzybfxs473390h4jq9ahm3xqdvy5zpchxy3y"))
(patches (search-patches
+ "openjdk-10-char-reproducibility.patch"
+ "openjdk-10-classlist-reproducibility.patch"
+ "openjdk-10-corba-reproducibility.patch"
"openjdk-10-idlj-reproducibility.patch"
+ "openjdk-10-module-reproducibility.patch"
+ "openjdk-10-module3-reproducibility.patch"
+ "openjdk-10-module4-reproducibility.patch"
+ "openjdk-10-jar-reproducibility.patch"
+ "openjdk-10-jtask-reproducibility.patch"
"openjdk-10-pointer-comparison.patch"
"openjdk-10-setsignalhandler.patch"
"openjdk-currency-time-bomb2.patch"))))
@@ -1241,6 +1249,11 @@ new Date();"))
;; this exact first line.
(substitute* "make/data/blacklistedcertsconverter/blacklisted.certs.pem"
(("^#!.*") "#! java BlacklistedCertsConverter SHA-256\n"))))
+ (add-after 'unpack 'remove-timestamping
+ (lambda _
+ (substitute* "./src/hotspot/share/runtime/vm_version.cpp"
+ (("__DATE__") "")
+ (("__TIME__") ""))))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(invoke "bash" "./configure"