summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorChristopher Baines <[email protected]>2023-03-02 10:37:28 +0000
committerChristopher Baines <[email protected]>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/graph.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm39
1 files changed, 37 insertions, 2 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 560764bb33..104fe07b58 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2019, 2020, 2022 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2017, 2018, 2019, 2020, 2022, 2023 Ricardo Wurmus <[email protected]>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <[email protected]>
;;; Copyright © 2018, 2020, 2022 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019, 2021, 2022 Efraim Flashner <[email protected]>
@@ -311,6 +311,41 @@ subplots, multiple-axes, polar charts, and bubble charts.")
algorithm for community detection in large networks.")
(license license:bsd-3)))
+(define-public python-vtraag-louvain
+ (package
+ (name "python-vtraag-louvain")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "louvain" version))
+ (sha256
+ (base32
+ "16l2zi4jwc3vpvpnz32jv7xy0g5087dp9y57wxplj1xa9r312x0i"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-use-bundled-igraph
+ (lambda _
+ (substitute* "setup.py"
+ (("self.external = False")
+ "self.external = True")
+ (("self.use_pkgconfig = False")
+ "self.use_pkgconfig = True")))))))
+ (inputs (list igraph))
+ (propagated-inputs (list python-igraph))
+ (native-inputs
+ (list pkg-config
+ python-ddt
+ python-setuptools-scm))
+ (home-page "https://github.com/vtraag/louvain")
+ (synopsis "Community detection in large networks")
+ (description
+ "Louvain is a general algorithm for methods of community detection in
+large networks.")
+ (license license:gpl3+)))
+
(define-public faiss
(package
(name "faiss")
@@ -555,7 +590,7 @@ of graphs.")
(list pkg-config))
(inputs
(list gd))
- (home-page "http://www.mcternan.me.uk/mscgen/")
+ (home-page "https://www.mcternan.me.uk/mscgen/")
(synopsis "Message Sequence Chart Generator")
(description "Mscgen is a small program that parses Message Sequence Chart
descriptions and produces PNG, SVG, EPS or server side image maps (ismaps) as