summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-11-06 11:44:01 +0200
committerEfraim Flashner <[email protected]>2024-11-06 12:49:39 +0200
commitfb9168d2c060e3041a791c16520c1bc472fd759b (patch)
tree698322767cb785df65a1a4d29e769a1dae7659b5 /gnu/packages/golang-xyz.scm
parentacd36c81722bf1fdb83787919ae4e419530194b0 (diff)
gnu: go-github-com-dgraph-io-ristretto: Disable tests when cross-compiling.
* gnu/packages/golang-xyz.scm (go-github-com-dgraph-io-ristretto) [arguments]: Also disable the tests when cross-compiling. Change-Id: I3addf5203366b6628af304a083ca5e5ce34250c3
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0d6debcac4..8390b905ed 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2019 Brian Leung <[email protected]>
;;; Copyright © 2019, 2021 Vagrant Cascadian <[email protected]>
;;; Copyright © 2019-2021 Martin Becze <[email protected]>
-;;; Copyright © 2019-2022 Efraim Flashner <[email protected]>
+;;; Copyright © 2019-2022, 2024 Efraim Flashner <[email protected]>
;;; Copyright © 2020 Alex Griffin <[email protected]>
;;; Copyright © 2020 Danny Milosavljevic <[email protected]>
;;; Copyright © 2020 Jack Hill <[email protected]>
@@ -2097,7 +2097,8 @@ supports concurrent serializable transactions.")
;;
;; cannot use 4340958203495 (untyped int constant) as int value in
;; argument to z.KeyToHash (overflows)
- #:tests? (target-64bit?)
+ #:tests? (and (target-64bit?)
+ (not (%current-target-system)))
#:import-path "github.com/dgraph-io/ristretto"
#:phases
#~(modify-phases %standard-phases