summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-07 15:01:20 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:42 +0000
commitd1245d600aec8c719ae6c2b85a5eb39897badac1 (patch)
treebb91a8f0332db513731c5e921b4858722d07959d /gnu/packages/golang-xyz.scm
parent4ffe1d1bd988348e9a06530fc2b871b319ba54f8 (diff)
gnu: Add go-github-com-apparentlymart-go-dump.
* gnu/packages/golang-xyz.scm (go-github-com-apparentlymart-go-dump): New variable. Change-Id: Icd9fa47dc754c93d9c455ef9c89242f57ffe0184
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3d1dce7d91..f4f3fd5d5e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -989,6 +989,31 @@ commands.")
"This package implements optimal parameters for data-types.")
(license license:expat)))
+(define-public go-github-com-apparentlymart-go-dump
+ (package
+ (name "go-github-com-apparentlymart-go-dump")
+ (version "0.0.0-20190214190832-042adf3cf4a0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apparentlymart/go-dump")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yqc50v82za54j2yy3ln7jzx983scb5gbh195wb6vmvqj18q696q"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:skip-build? #t
+ #:import-path "github.com/apparentlymart/go-dump"))
+ (home-page "https://github.com/apparentlymart/go-dump")
+ (synopsis "Utility for formatting Go values in a pretty-printed way")
+ (description
+ "This package implements a functionality for generating pretty-printed
+dumps of Go values.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-apparentlymart-go-textseg-v9
(package
(name "go-github-com-apparentlymart-go-textseg-v9")