summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-11 15:03:27 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:58 +0000
commitcc8ff5be2e487c50092731682b79cfeaeb0afb7f (patch)
tree0f7b6eec183b0a05b578dc7ffa432c7b186dd1ca /gnu/packages/golang-xyz.scm
parent9f3da826e1ee6a43252f0f6ffa7f16567d5403f2 (diff)
gnu: Add go-github-com-xtgo-uuid.
* gnu/packages/golang-xyz.scm (go-github-com-xtgo-uuid): New variable. Change-Id: I4b18996fe59ca752ac4e471d4ada63ce98b66745
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 009df8da03..615bd48e45 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -15077,6 +15077,30 @@ popular Levenshtein distance (aka Edit Distance or Wagner-Fischer), as well as
the Jaro distance, the Jaro-Winkler distance, and more.")
(license license:expat)))
+(define-public go-github-com-xtgo-uuid
+ (package
+ (name "go-github-com-xtgo-uuid")
+ (version "0.0.0-20140804021211-a0b114877d4c")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xtgo/uuid")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10pmay90is5x8cv5ckcajw3s7g2rpk4ix6kl4qhq8qx05x2ivlrw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/xtgo/uuid"))
+ (home-page "https://github.com/xtgo/uuid")
+ (synopsis "Go UUID parsing and generation")
+ (description
+ "Package uuid can be used to generate and parse universally unique
+identifiers, a standardized format in the form of a 128 bit number.")
+ (license license:bsd-3)))
+
(define-public go-github-com-xuanwo-go-locale
(package
(name "go-github-com-xuanwo-go-locale")