summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-09 12:48:56 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:49 +0000
commit9afa4eb17c2ac1a37196f912b415d7d0b2c5a0ad (patch)
treebd869e39022a5a537769b88c0fcf44846078d7f0 /gnu/packages/golang-xyz.scm
parent5f0bb9245118ffb40755cdaac6a4464baf56b313 (diff)
gnu: go-github-com-twpayne-go-vfs-v5: Simplify.
* gnu/packages/golang-xyz.scm (go-github-com-twpayne-go-vfs-v5) [arguments] <phases>: Use default 'check. Change-Id: I7857a7d9ab6334188ca8cb40ad71af2d7790298b
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 826ac5ba98..693104f995 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -13255,15 +13255,7 @@ supported by the time package
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/twpayne/go-vfs/v5"
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX: Replace when go-build-system supports nested path.
- (replace 'check
- (lambda* (#:key import-path tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v" "./..."))))))))
+ #:import-path "github.com/twpayne/go-vfs/v5"))
(native-inputs
(list go-github-com-alecthomas-assert-v2))
(home-page "https://github.com/twpayne/go-vfs/")