summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-09 13:24:15 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:49 +0000
commit98f7346225ff1cc43755a00ae0e98b448c2283eb (patch)
treeab05f04f1056be0df9ee7516dff58921fab20add /gnu/packages/golang-xyz.scm
parent98f1850f59a607d7c83f4193db3acfaf0ad9eba5 (diff)
gnu: go-github-com-bradfitz-gomemcache: Move to golang-xyz.
* gnu/packages/databases.scm (go-github-com-bradfitz-gomemcache): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I0592af69046c5b9aa85f6a3ec0efc56ffe5f1004
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 18e541b541..c16467ea59 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1951,6 +1951,30 @@ project is to provide a simple, fast, and reliable database for projects that
don't require a full database server such as Postgres or MySQL.")
(license license:expat)))
+(define-public go-github-com-bradfitz-gomemcache
+ (package
+ (name "go-github-com-bradfitz-gomemcache")
+ (version "0.0.0-20230905024940-24af94b03874")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bradfitz/gomemcache")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xhf5zphhilv1jiwsdf5f4b4g2jj8q3yhn2r83f52mpi9s8jp5db"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:skip-build? #t
+ #:import-path "github.com/bradfitz/gomemcache"))
+ (home-page "https://github.com/bradfitz/gomemcache")
+ (synopsis "Memcache client library in Go")
+ (description
+ "This is a memcache client library for the Go programming language.")
+ (license license:asl2.0)))
+
(define-public go-github-com-briandowns-spinner
(package
(name "go-github-com-briandowns-spinner")