summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-25 08:29:09 +0000
committerSharlatan Hellseher <[email protected]>2025-01-25 08:44:22 +0000
commit93f3bf0a16d72dbb51027c5519079e8c400c83a4 (patch)
tree45eca48573e683a18a7a0c4993f88b188ab4d5ae /gnu/packages/golang-xyz.scm
parentf4043c08fd8a2b29778937762728e2ffcdf970ed (diff)
gnu: Add go-github-com-xaionaro-gosrc.
* gnu/packages/golang-xyz.scm (go-github-com-xaionaro-gosrc): New variable. Change-Id: Ie7726ed53c7c4d98aa58e2afbe600073b8a9c4b1
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9e0b391956..cb17c10756 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -15382,6 +15382,38 @@ edges and self-loops are not permitted.
@code{[]byte}.")
(license license:cc0)))
+(define-public go-github-com-xaionaro-gosrc
+ (let ((commit "3fdf8476a735bd7ddd90579862e2e548787b17b6")
+ (revision "0"))
+ (package
+ (name "go-github-com-xaionaro-gosrc")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xaionaro-go/gosrc")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j0y0r0nj39537x7yk9yfc3k6dqbw14b65ykjnbmsxkhpjjpxf3v"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/xaionaro-go/gosrc"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-xaionaro-go-unsafetools
+ go-github-com-fatih-structtag))
+ (home-page "https://github.com/xaionaro-go/gosrc")
+ (synopsis "Parse Go packages to handy structures")
+ (description
+ "This package just simplifies working with @code{go/*} packages to parse
+a source code. Initially the package was written to simplify code
+generation.")
+ (license license:cc0))))
+
(define-public go-github-com-xdg-go-stringprep
(package
(name "go-github-com-xdg-go-stringprep")