summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-10 21:16:51 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:55 +0000
commit8f94d7052db04ea342166073d9f92a562ea84c2e (patch)
tree29b8606a6aa292a7a75f7439dafd27970cc1b8b2 /gnu/packages/golang-xyz.scm
parent79fcf255bdf5b73e293a403a94f2411eff09c484 (diff)
gnu: go-github-com-olekukonko-ts: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-olekukonko-ts): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ibb66ec8c55070c839ae5e544f4ce01f8d3d6e8c5
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9962caa097..08cd006bfd 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -11302,6 +11302,31 @@ millisecond)
@end itemize")
(license license:expat)))
+(define-public go-github-com-olekukonko-ts
+ (package
+ (name "go-github-com-olekukonko-ts")
+ (version "0.0.0-20171002115256-78ecb04241c0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/olekukonko/ts")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k88n5rvs5k5zalbfa7c71jkjb8dhpk83s425z728qn6aq49c978"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:tests? #f ; inappropriate ioctl for device.
+ #:import-path "github.com/olekukonko/ts"))
+ (home-page "https://github.com/olekukonko/ts/")
+ (synopsis "Simple Go application to get the size of the terminal")
+ (description
+ "This package provides a simple Go application to get the size of the
+terminal.")
+ (license license:expat)))
+
(define-public go-github-com-op-go-logging
(package
(name "go-github-com-op-go-logging")